“The Missing Manual series is simply the most intelligent and usable series of guidebooks.”
—KEVIN KELLY, COFOUNDER OF WIRED

macOS Sierra

the missing manual

The book that should have been in the box®

Covers the new Touch Bar MacBooks

Free Sampler

David Pogue
Answers found here!

Apple’s latest operating system, macOS Sierra, brings the Siri voice assistant to the Mac—and much more. What it still doesn’t offer, though, is even a single page of printed instructions. Fortunately, David Pogue is back, delivering the expertise and humor that have made this the #1 bestselling Mac book for 15 years in a row.

The important stuff you need to know


- **Nips and tucks.** This book demystifies all the smaller enhancements, too, in the 50 programs that come with the Mac: Safari, Mail, Messages, Maps, Preview...

- **Shortcuts.** This must be the tippiest, trickiest Mac book ever written. Undocumented surprises await on every page.

- **Power users.** Security, networking, remote access, file sharing with Windows—this one witty, expert guide makes it all crystal clear.

MacOS Sierra gives the Mac more polish, power, and pep—and in your hands, you hold the ultimate guide to unlocking its potential.
Want to read more?

You can **buy this book** at oreilly.com in print and ebook format.

**Buy 2 books, get the 3rd FREE!**

Use discount code OPC10

All orders over $29.95 qualify for **free shipping** within the US.

It’s also available at your favorite book retailer, including the iBookstore, the [Android Marketplace](http://androidmarket.com), and [Amazon.com](http://amazon.com).
# Table of Contents

The Missing Credits ................................................................. xiii

## Introduction ........................................................................ 1
  - What’s New in Sierra ......................................................... 1
  - About This Book ............................................................ 4
  - The Very Basics ............................................................ 6

## Part One: The macOS Desktop ........................................ 11

### Chapter 1: Folders, Windows & Finder Tabs .................. 11
  - Getting into macOS ....................................................... 11
  - Windows and How to Work Them .................................. 15
  - The Four Window Views ............................................... 31
  - Icon View ................................................................. 33
  - List View ....................................................................... 43
  - Column View .................................................................. 50
  - Cover Flow View .......................................................... 53
  - Keep Folders on Top ...................................................... 55
  - The Preview Pane ......................................................... 55
  - Quick Look ..................................................................... 56
  - Finder Tabs ..................................................................... 61
  - Tabs in Other Apps ....................................................... 63
  - Logging Out, Shutting Down ......................................... 64
  - Getting Help in macOS ................................................ 66

### Chapter 2: Organizing Your Stuff ................................. 69
  - The macOS Folder Structure .......................................... 69
  - Icon Names ..................................................................... 74
  - Selecting Icons ............................................................ 77
  - Moving and Copying Icons .......................................... 81
  - Aliases: Icons in Two Places at Once ............................ 86
  - Finder Tags ...................................................................... 88
  - The Trash .................................................................... 93
  - Get Info .......................................................................... 96
  - Shortcut Menus, Action Menus ...................................... 100
  - Optimized Storage ....................................................... 102
# Table of Contents

## Part One: macOS 10.15 — Catalina

### Chapter 3: Spotlight ................................................................. 107
- The Spotlight Menu .................................................................... 107
- The Searching Window .............................................................. 120
- Customizing Spotlight .............................................................. 132
- Smart Folders ........................................................................... 134

### Chapter 4: Dock, Desktop & Toolbars ................................... 137
- The Dock .................................................................................. 137
- Setting Up the Dock ................................................................. 138
- Using the Dock .......................................................................... 145
- The Finder Toolbar .................................................................... 151
- Designing Your Desktop .......................................................... 155
- Menulets: The Missing Manual .................................................. 157

## Part Two: Programs in macOS

### Chapter 5: Documents, Programs & Mission Control .......... 163
- The Mac App Store .................................................................... 163
- Other Ways to Get Mac Software ............................................. 165
- Opening macOS Programs ....................................................... 167
- Launchpad .................................................................................. 168
- Windows That Auto-Reopen .................................................... 173
- The Application Menu .............................................................. 175
- The “Heads-Up” Program Switcher ........................................ 176
- Full Screen Mode ....................................................................... 177
- Split Screen Mode ..................................................................... 179
- Mission Control: Death to Window Clutter ......................... 182
- Spaces (Virtual Desktops) ....................................................... 186
- Dashboard ................................................................................ 191
- Exposé .................................................................................... 195
- Hiding Programs the Old-Fashioned Way .............................. 200
- How Documents Know Their Parents .................................... 202
- Keyboard Control .................................................................... 207
- The Save and Open Dialog Boxes ......................................... 212
- Auto Save and Versions .......................................................... 217
- iCloud Drive ........................................................................... 221
- The Cocoa Advantage .............................................................. 225

### Chapter 6: Data: Typing, Sharing & Backing Up ............... 229
- The Mac Keyboard .................................................................... 229
- The Touch Bar + Fingerprint Reader ....................................... 233
- Notes on Right-Clicking ............................................................ 239
- Power Typing ........................................................................... 241
- The Many Languages of macOS Text ..................................... 247
- Ink: Handwriting Recognition .................................................. 252

---

**TABLE OF CONTENTS**
<table>
<thead>
<tr>
<th>Chapter 11: The Free Programs of macOS</th>
<th>385</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your Free Programs</td>
<td>385</td>
</tr>
<tr>
<td>App Store</td>
<td>386</td>
</tr>
<tr>
<td>Automator</td>
<td>386</td>
</tr>
<tr>
<td>Calculator</td>
<td>386</td>
</tr>
<tr>
<td>Calendar</td>
<td>388</td>
</tr>
<tr>
<td>Chess</td>
<td>403</td>
</tr>
<tr>
<td>Contacts</td>
<td>405</td>
</tr>
<tr>
<td>Dashboard</td>
<td>405</td>
</tr>
<tr>
<td>Dictionary</td>
<td>405</td>
</tr>
<tr>
<td>DVD Player</td>
<td>407</td>
</tr>
<tr>
<td>FaceTime</td>
<td>407</td>
</tr>
<tr>
<td>Font Book</td>
<td>410</td>
</tr>
<tr>
<td>GarageBand</td>
<td>410</td>
</tr>
<tr>
<td>iBooks</td>
<td>411</td>
</tr>
<tr>
<td>Image Capture</td>
<td>417</td>
</tr>
<tr>
<td>iMovie</td>
<td>422</td>
</tr>
<tr>
<td>iPhoto</td>
<td>422</td>
</tr>
<tr>
<td>iTunes</td>
<td>422</td>
</tr>
<tr>
<td>Launchpad</td>
<td>432</td>
</tr>
<tr>
<td>Mail</td>
<td>432</td>
</tr>
<tr>
<td>Maps</td>
<td>433</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 10: Notifications</th>
<th>375</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insta-Respond to Bubbles</td>
<td>376</td>
</tr>
<tr>
<td>Shutting Up the Bubbles</td>
<td>376</td>
</tr>
<tr>
<td>The Notification Center</td>
<td>378</td>
</tr>
</tbody>
</table>

| Network | 363 |
| Notifications | 363 |
| Parental Controls | 364 |
| Printers & Scanners | 364 |
| Security & Privacy | 364 |
| Sharing | 364 |
| Siri | 364 |
| Sound | 365 |
| Spotlight | 367 |
| Startup Disk | 367 |
| Time Machine | 367 |
| Touch ID | 367 |
| Trackpad | 369 |
| Users & Groups | 374 |

| Network | 363 |
| Sharing | 364 |
| Contacts | 405 |
| Chess | 403 |
| Calendar | 388 |
| Calculator | 386 |
| FaceTime | 407 |
| DVD Player | 407 |
| Font Book | 410 |
| GarageBand | 410 |
| iBooks | 411 |
| Image Capture | 417 |
| iMovie | 422 |
| iPhoto | 422 |
| iTunes | 422 |
| Launchpad | 432 |
| Mail | 432 |
| Maps | 433 |
# Table of Contents

## Chapter 14: Graphics, Fonts & Printing .............................................. 591

- Mac Meets Printer .................................................................................. 591
- Making the Printout ................................................................................ 594
- Managing Printouts ................................................................................ 597
- Printer Sharing ...................................................................................... 598
- Faxing ..................................................................................................... 599
- PDF Files ................................................................................................. 600
- Fonts—and Font Book ............................................................................ 602
- ColorSync ............................................................................................... 610
- Graphics in macOS .................................................................................. 611
- Screen-Capture Keystrokes ................................................................... 612

## Chapter 15: Movies & Sound ............................................................... 615

- QuickTime Player ................................................................................... 615
- Playing Sounds ...................................................................................... 625
- Recording Sounds .................................................................................. 627

## Part Five: macOS Online

## Chapter 16: Internet Setup & iCloud ................................................... 631

- The Best News You’ve Heard All Day .................................................... 632
- Network Central and Multihoming ......................................................... 632
- Broadband Connections ......................................................................... 634
- Cellular Modems .................................................................................... 640
- Tethering (Personal Hotspot) ................................................................. 640
- Dial-Up Modem Connections ............................................................... 641
- Switching Locations ............................................................................... 641
- Internet Sharing ..................................................................................... 643
- Meet iCloud ............................................................................................. 646
- iCloud Drive ........................................................................................... 646
- Photos ..................................................................................................... 647
- Email Address ......................................................................................... 650
- Data Synchronization ............................................................................. 651
- Find My Mac, Find My iPhone .............................................................. 652
- Family Sharing ....................................................................................... 654
- Back to My Mac ...................................................................................... 659
- Apple Pay on the Web ........................................................................... 659
- More iCloud Features ............................................................................ 661
# Chapter 17: Mail & Contacts .............................................................. 663
- Setting Up Mail .......................................................... 663
- Checking Your Mail ................................................... 665
- Tailoring the Look of Mail ........................................... 666
- Writing Messages ...................................................... 666
- Stationery ..................................................................... 682
- Reading Email .......................................................... 682
- VIPs ........................................................................... 700
- The Anti-Spam Toolkit ............................................... 702
- Contacts ...................................................................... 703

# Chapter 18: Safari ........................................................................... 715
- The Unified Address/Search Bar .................................. 715
- Bookmarks, Favorites, and Top Sites .......................... 720
- Full Screen and Gestures ............................................ 725
- Scrolling ........................................................................ 726
- Five Ways to Magnify a Page ....................................... 726
- Customizing the Toolbar ............................................. 727
- Saved Passwords: The iCloud Keychain ..................... 728
- Tabbed Browsing ........................................................ 734
- Tips for Better Surfing ................................................. 738
- Privacy and Security Features .................................... 748

# Chapter 19: Messages .................................................................... 751
- Welcome to Messages ................................................ 751
- Setting Up Messages .................................................. 752
- Let the Chat Begin ..................................................... 754
- iMessages ................................................................. 756
- Other Chat Networks ................................................ 760
- Sharing Your Screen .................................................. 765

# Chapter 20: FTP, SSH, VPN & Web Sharing ................................. 769
- FTP ............................................................................. 769
- Connecting from the Road .......................................... 771
- Remote Access with SSH ......................................... 772
- Virtual Private Networking ....................................... 775
# Part Six: Appendixes

## Appendix A: Installing macOS Sierra

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware Requirements</td>
<td>784</td>
</tr>
<tr>
<td>The Standard Installation</td>
<td>784</td>
</tr>
<tr>
<td>The Setup Assistant</td>
<td>788</td>
</tr>
<tr>
<td>The Homemade Installer Disk</td>
<td>792</td>
</tr>
</tbody>
</table>

## Appendix B: Troubleshooting

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slowdowns and Fans</td>
<td>793</td>
</tr>
<tr>
<td>Minor Eccentric Behavior</td>
<td>794</td>
</tr>
<tr>
<td>Frozen Programs (Force Quitting)</td>
<td>795</td>
</tr>
<tr>
<td>Application Won’t Open</td>
<td>796</td>
</tr>
<tr>
<td>Startup Problems</td>
<td>796</td>
</tr>
<tr>
<td>Recovery Mode: Three Emergency Disks</td>
<td>799</td>
</tr>
<tr>
<td>Fixing the Disk</td>
<td>802</td>
</tr>
<tr>
<td>Where to Get Troubleshooting Help</td>
<td>805</td>
</tr>
</tbody>
</table>

## Appendix C: The Windows-to-Mac Dictionary

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>807</td>
</tr>
</tbody>
</table>

## Appendix D: The Master Secret Keystroke List

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>819</td>
</tr>
</tbody>
</table>
Folders, Windows & Finder Tabs

These days, the graphic user interface (icons, windows, Trash cans) is standard. MacOS, Windows, Chrome OS, Android, iOS—every operating system is fundamentally the same, and a very long way from the lines of typed commands that defined the earliest computers.

That’s not to say that the graphic interface hasn’t evolved, though; it has. Herewith: a grand tour of the state of the art in computer desktops—the one in Sierra.

Getting into macOS

When you first turn on a Mac running macOS, an Apple logo greets you, soon joined by a skinny progress bar that lets you know how much longer you have to wait.

Logging In

What happens next depends on whether you’re the Mac’s sole proprietor or have to share it with other people in an office, school, or household.

• If it’s your own Mac, and you’ve already been through the setup process described in Appendix A, no big deal. You arrive at the macOS desktop.

• If it’s a shared Mac, you may encounter the login screen, shown in Figure 1-1. It’s like a portrait gallery, set against a blurry version of your usual desktop picture. Click your icon.

If the Mac asks for your password, type it and then click Log In (or press Return). You arrive at the desktop. Or, if your Mac has a Touch Bar (page 233) and you’ve registered your fingerprint, then touch that finger to the sensor at the right end of the bar.
Chapter 12 offers much more on this business of accounts and logging in.

Note: In certain especially paranoid workplaces, you may not see the rogue's gallery shown in Figure 1-1. You may just get two text boxes, where you're supposed to type in your name and password. Without even the icons of known account holders, an evil hacker's job is that much more difficult.

The Elements of the macOS Desktop

The desktop is the shimmering, three-dimensional macOS landscape shown in Figure 1-2. On a new Mac, it's covered by a photo of a spectacular, rugged mountain range—California's Sierra Nevada mountains (get it?). If you upgraded from an earlier version of macOS, you keep whatever desktop picture you had before.

If you've ever used a computer before, most of the objects on your screen are nothing more than updated versions of familiar elements. Here's a quick tour.

The Dock

This translucent row of colorful icons is a launcher for the programs, files, folders, and disks you use often—and an indicator to let you know which programs are already open. They appear to rest on a sheet of transparent, smoked glass.

In principle, the Dock is very simple:

- **Programs go on the left side.** Everything else goes on the right, including documents, folders, and disks. (Figure 1-2 shows the dividing line.)
• You can add a new icon to the Dock by dragging it there. Rearrange Dock icons by dragging them. Remove a Dock icon by dragging it away from the Dock. (The cute little animated puff of smoke is gone in Sierra.) You can’t, however, remove the icon of a program that’s currently open.

• Click something once to open it. When you click a program’s icon, a tiny black dot appears under it to let you know it’s open.

When you click a folder’s icon, you get a stack—an arcing row of icons, or a grid of them, that indicates what’s inside. See page 140 for more on stacks.

• Each Dock icon sprouts a pop-up menu. To see the menu, hold the mouse button down on a Dock icon—or right-click it, or two-finger click it. A shortcut menu of useful commands pops right out.

• If you have a trackpad, you can view miniatures of all open windows in a program by pointing to its Dock icon and then swiping down with three fingers. Details on how to turn on this feature are on page 195.

Because the Dock is such a critical component of macOS, Apple has decked it out with enough customization controls to keep you busy experimenting for months. You can change its size, move it to the sides of your screen, hide it entirely, and so on. Chapter 4 contains complete instructions for using and understanding the Dock.
The 🍏 menu

The 🍏 menu houses important Mac-wide commands like Sleep, Restart, and Shut Down. They’re always available, no matter which program you’re using.

The menu bar

Every popular operating system saves space by concealing its most important commands in menus that drop down. MacOS’s menus are especially refined:

- **They stay down.** MacOS menus stay open until you click the mouse, trigger a command from the keyboard, or buy a new computer, whichever comes first.

  **Tip:** Actually, menus are even smarter than that. If you give the menu name a quick click, the menu opens and stays open. If you click the menu name and hold the mouse button down for a moment, the menu opens but closes again when you release the button. Apple figures that, in that case, you’re just exploring, reading, or hunting for a certain command.

- **They’re consistently arranged.** The first menu in every program, which appears in bold lettering, tells you at a glance what program you’re in (Safari, Microsoft Word, whatever). The commands in this Application menu include About (which indicates what version of the program you’re using), Preferences, Quit, and commands like Hide Others and Show All (which help control window clutter, as described on page 201). In short, all the Application menu’s commands actually pertain to the application you’re using.

  The File and Edit menus come next. The File menu contains commands for opening, saving, and closing files. (See the logic?) The Edit menu contains the Cut, Copy, and Paste commands.

  The last menu is almost always Help. It opens a miniature web browser that lets you search the online Mac help files for explanatory text.

- **You can operate them from the keyboard.** Once you’ve clicked open a menu, you can highlight any command in it just by typing the first letter (g for Get Info, for example). It’s especially great for “Your country” pop-up menus on websites, where “United States” is about 200 countries down in the list. You can type united s to jump right to it.

  You can also press Tab to open the next menu, Shift-Tab to open the previous one, and Return to “click” the highlighted command.

- **They can hide themselves.** You can set things up so that the menu bar disappears completely when you’re not using it. You get a little more room on your screen. Particularly if you use keyboard shortcuts for menu commands, why should the menu bar just sit there all day, eating up space?

  The on/off switch for this menu-hiding feature is in System Preferences ➔ General; turn on “Automatically hide and show the menu bar.” Then, when you do want to
open a menu manually, just move your cursor to the top edge of the screen; the menu bar reappears.

**Disk icons on the desktop**

For years, Apple has encouraged its flock to keep a clean desktop, to get rid of all the icons that many of us leave strewn around. Especially the hard drive icon, which had appeared in the upper-right corner of the screen since the original 1984 Mac.

Today, the Macintosh HD icon doesn’t appear on the screen. “Look,” Apple seems to be saying, “if you want access to your files and folders, just open them directly—from the Dock or from your Home folder (page 70). Most of the stuff on the hard drive is system files of no interest to you, so let’s just hide that icon, shall we?”

If you’d prefer that the disk icons return to your desktop, then choose Finder → Preferences, click General, and turn on the checkboxes of the disks whose icons you want on the desktop: hard disks, external disks, CDs, and so on.

**Windows and How to Work Them**

In designing macOS, one of Apple’s key goals was to address the window-proliferation problem. As you create more files, stash them in more folders, and launch more programs, it’s easy to wind up paralyzed before a screen awash with overlapping rectangles.

That’s the problem admirably addressed by Mission Control, described in detail on page 182. Some handy clutter and navigation controls are built into the windows themselves, too. For example:

**The Sidebar**

The Sidebar (Figure 1-3) is the pane at the left side of every Finder window, unless you’ve hidden it. (It’s also at the left side of every Open dialog box and every full-sized Save dialog box.) It’s slightly translucent—your desktop picture shines through it just a little bit.

The Sidebar has as many as four sections, each preceded by a collapsible heading.

**Tip**: If you point to a heading without clicking, a tiny Hide or Show button appears. Click it to collapse or expand that heading’s contents.

Here are the headings you’ll soon know and love. (You can drag these headings up and down in the Sidebar to rearrange them.)

- **Favorites**. This primary section of the Sidebar is the place to stash things for easy access. You can stock this list with the icons of disks, files, programs, folders, and the virtual, self-updating folders called *saved searches*.

  Each icon is a shortcut. For example, click the Applications icon to view the contents of your Applications folder in the main part of the window. And if you click the icon of a file or a program, it opens.
Here, too, you’ll find the icons for important Mac features like All My Files (see the box on page 18); AirDrop, the instant file-sharing feature described on page 558; and the fantastic iCloud Drive (page 221).

• **Shared**. Here’s a complete list of the other computers on your network whose owners have turned on File Sharing, ready for access (see Chapter 13 for details). Back to My Mac (page 589) may also be listed here.

• **Devices**. This section lists every storage device connected to, or installed inside, your Mac: hard drives, iPhones, iPads, iPods, CDs, DVDs, memory cards, USB flash drives, and so on. (Your main hard drive doesn’t usually appear, but you can drag it here.) The removable ones (like CDs, DVDs, and i-gadgets) bear a little gray eject logo, which you can click to eject that disk.

• **Tags**. This section lists all your Finder tags (color-coded keywords). See page 88 for more on tags.

---

**Figure 1-3:**
Good things to put in the Sidebar: favorite programs, disks on a network you often connect to, a document you’re working on every day, and so on. You can drag a document onto a folder icon to file it there, drag a document onto a program’s icon to open it with the “wrong” program, and so on.
**Note:** If you remove everything listed under one of these headings, the heading itself disappears to save space. The heading reappears the next time you put something in its category back into the Sidebar.

**Fine-tuning the Sidebar**

The beauty of this parking lot for containers is that it’s so easy to set up with your favorite places. For example:

- **Remove an icon** by dragging it out of the Sidebar entirely. It vanishes. You haven’t actually removed anything from your Mac; you’ve just unhitched its alias from the Sidebar.

**Tip:** You can’t drag items out of the Shared list. Also, if you drag a Devices item out of the list, you’ll have to choose Finder → Preferences → Sidebar and then turn on the appropriate checkbox to put it back in.

- **Rearrange the icons** by dragging them up or down in the list. For example, hard drives don’t appear at the top of the Sidebar as in the olden days, but you’re free to drag them back into those coveted spots. (You’re not allowed to rearrange the computers listed in the Shared section, though.)

- **Rearrange the sections** by dragging them up or down. For example, you can drag Favorites to the bottom but promote the Shared category.

- **Install a new icon** by dragging it off your desktop (or out of a window) into any spot in the Favorites list of the Sidebar; a horizontal line shows where it will land after you let go. You can’t drag icons into any section of the Sidebar—just Favorites.

**Tip:** You can also highlight an icon wherever it happens to be and then choose File → Add to Sidebar, or just press Control-`T`.

---

**UP TO SPEED**

**Fixing the Sidebar**

Anything you drag out of the Sidebar can be dragged back in again, including the big-ticket items like Applications and Pictures. That’s good to know if you drag something important out of the Sidebar and then change your mind.

Even so, there’s a quicker way to restore the Sidebar to its factory settings.

If you choose Finder → Preferences and then click the Sidebar button, you discover the checkboxes shown here. They let you put back the Apple-installed icons that you may have removed in haste. Just turn on a checkbox to restore its icon to your Sidebar. So if something you expect to see in your Sidebar isn’t there, check back here.

On the other hand, you may as well streamline your computing life by turning off the checkboxes of icons you never want to see filling your Sidebar.
• Adjust the width of the Sidebar by dragging its right edge—either the skinny divider line or the extreme right edge of the vertical scroll bar, if there is one. You “feel” a snap at the point when the line covers up about half of each icon’s name. Any covered-up names sprout ellipses (…) to let you know there’s more (as in “Secret Salaries Spreadsh…”).

• Hide the Sidebar by pressing ⌘-Option-S, which is the shortcut for the View→Hide Sidebar command. Bring the Sidebar back into view by pressing the same key combination (or by using the Show Sidebar command).

**Tip:** You can hide and show the Sidebar manually, too: To hide it, drag its right edge all the way to the left edge of the window. Unhide it by dragging the left edge of the window to the right again.

Then again, why would you ever want to hide the Sidebar? It’s one of the handiest navigation aids since the invention of the steering wheel. For example:

---

**UP TO SPEED**

**All My Files**

There it is, staring you in the face at the top of the Sidebar in every window: an icon called All My Files. What is this, some kind of geeked-out soap opera?

Nope. It’s a massive, searchable, sortable list, all in a single window, of every human-useful file on the computer. That is, pictures, movies, music, documents—no system files, preference files, or other detritus. No matter what folders they’re actually in, they appear here in a single window. You can summon it whenever you want, just by clicking the All My Files icon in the Sidebar.

When you first open All My Files, it has your files grouped by type: Contacts, Events & To Dos, Images, PDF Documents, Music, Movies, Presentations, Spreadsheets, Developer (which lists HTML website files and Xcode programming files), and Documents (meaning “everything else”). In icon view—the factory setting—each class of icons appears in a single scrolling row. Use a two-finger scroll (trackpad) or one-finger slide (Magic Mouse) to move through the horizontal list. (If you’d rather not have to scroll, click the tiny Show All button that appears at the right end of each row. Now you’re seeing all the icons of this type; click Show Less to return to the single-row effect.)

You can see how this sorting method—which is the Arrange By command at work (page 39)—might be useful. Suppose you’re looking for a certain PowerPoint or Keynote presentation, but you can’t remember what you called it or where you filed it. Open All My Files, make sure it’s arranged by Kind, and presto: You’re looking at a list of every presentation file on your Mac. Using Quick Look (page 56), you can breeze through them, inspecting them one at a time, until you find the one you want.

Apple thinks you’ll like All My Files as a starting point for standard file-fussing operations so much that All My Files is the window that appears automatically when you choose File→New Finder Window (or press ⌘-N). (Of course, you can change that in Finder→Preferences.)
• It takes a lot of pressure off the Dock. Instead of filling up your Dock with folder icons (all of which are frustratingly alike and unlabeled anyway), use the Sidebar to store them. You leave the Dock that much more room for programs and documents.

• It’s better than the Dock. In some ways, the Sidebar is a lot like the Dock, in that you can stash favorite icons of any sort there. But the Sidebar reveals the names of these icons, and the Dock doesn’t until you use the mouse to point there.

• It makes ejecting easy. Just click the button next to any removable disk to make it pop out.

• It makes burning easy. When you’ve inserted a blank CD or DVD and loaded it up with stuff you want to copy, click the button next to its name to begin burning that disc.

• You can drag onto its folders and disks. That is, you can drag icons onto Sidebar icons, exactly as though they were the real disks, folders, and programs they represent.

• It simplifies connecting to networked disks. Park your other computers’ shared folder and disk icons here, as described in Chapter 13, to shave several steps off the usual connecting-via-network ritual.

Title Bar
The title bar (Figure 1-4) has several functions. First, when a bunch of windows are open, the darkened title bar, window name, mini-icon, and colored left-corner buttons...
tell you which window is active—in front. (In background windows, these elements appear dimmed and colorless.) Second, the title bar acts as a handle that lets you move the window around on the screen.

You can also move a window by dragging the solid gray strip on the bottom, assuming you’ve made it appear (choose View→Show Status Bar).

**Tip:** Here’s a nifty keyboard shortcut: You can cycle through the different open windows in one program without using the mouse. Just press &~ (that is, the tilde key, to the left of the number 1 key on U.S. keyboards). With each press, you bring a different window forward within the current program. It works both in the Finder and in your everyday programs, and it beats the pants off using the mouse to choose a name from the Window menu. (Note the difference from & Tab, which cycles through different open programs.)

After you’ve opened one folder that’s inside another, the title bar’s secret folder hierarchy menu is an efficient way to backtrack—to return to the enclosing window. Get in the habit of right-clicking (or two-finger clicking, or Control-clicking, or &clicking) the name of the window to access the menu shown in Figure 1-5. (You can release the Control or & key immediately after clicking.)

**Figure 1-5:**
Right-click or two-finger click a Finder window’s title bar to summon the hidden folder hierarchy menu. This trick also works in most other macOS programs. For example, you can right-click a document window’s title to find out where the document is actually saved on your hard drive.

By choosing the name of a folder from this menu, you open the corresponding window. When browsing the contents of the Users folder, for example, you can return to the main hard drive window by right-clicking or two-finger clicking the folder name “Users” and then choosing Macintosh HD from the menu.

**Tip:** Keyboard lovers, take note. Instead of using the title bar menu, you can also jump to the enclosing window by pressing & (up arrow), which is the shortcut for the Go→Enclosing Folder command. Pressing & (down arrow) takes you back into the folder you started in, assuming that it’s still highlighted. (This makes more sense when you try it than when you read it.)
Once you’ve mastered dragging, you’re ready for these title bar tips:

- **Pressing the ⌘ key** lets you drag the title bar of an inactive window—one that’s partly covered by a window in front—without bringing it to the front. (Drag any empty part of the title bar—not the title itself.)

  By the way, you can close, minimize, or full-screenize a background window without the help of the ⌘ key. Just click one of those three corresponding title-bar buttons normally, even if the window you’re working on is in front of it.

- **Double-clicking the title bar** is a special technique: It *zooms* the window, enlarging it enough to reveal all the icons inside it (or, in programs, large enough to reveal all the text, graphics, or music). If your monitor isn’t big enough to show all the icons in a window, then the window grows to show as many as possible.

  With a quick visit to System Preferences → Dock, though, you can change things up. You can turn on “Double-click a window’s title bar to minimize.” Now double-clicking the title bar makes the window collapse into the Dock, exactly as though you had clicked the Minimize button.

  **Tip:** If you’ve turned on that “minimize” option, then you can minimize all desktop windows, sending them flying to the Dock, when you double-click the title bar while pressing the Option key.

---

**Close Button**

As the tip of your cursor crosses the three buttons at the upper-left corner of a window, tiny symbols appear inside them: ⌁, ⌉, and ⌇. Ignore the gossip that these symbols were added to help color-blind people who can’t distinguish the colors red, yellow, and green. Color-blind people are perfectly capable of distinguishing the buttons by their positions, just as they do with traffic lights.

But for people who aren’t paying attention to button position, these cues distinguish the buttons when all three are identical shades of gray, as they are when you use Graphite mode (page 156). They also signal when it’s time to click. For example, as described in the previous section, you can use these three buttons even when the window is not at the front. You know the buttons are ripe for the clicking when you see the little symbols appear under your cursor.

The most important window gadget is the Close button, the red, droplet-like button in the upper-left corner (see Figure 1-4). Clicking it closes the window, which collapses back into the icon from which it came.

  **Tip:** If, while working on a document, you see a tiny dot in the center of the Close button, macOS is trying to tell you that you haven’t yet saved your work. (It doesn’t appear in Auto Save programs like TextEdit.) The dot goes away when you save the document.

The universal keyboard equivalent of the Close button is ⌘-W (for window)—a keystroke well worth memorizing. If you get into the habit of dismissing windows
with that deft flick of your left hand, you’ll find it far easier to close several windows in a row, because you won’t have to aim for successive Close buttons.

In many programs, something special happens if you’re pressing the Option key when using the Close button or its  ⌘-W equivalent: You close all open windows. This trick is especially useful in the Finder, where a quest for a particular document may have left your screen plastered with open windows for which you have no further use. Option-clicking the Close button of any one window (or pressing Option- ⌘-W) closes all of them.

The Option-key trick doesn’t close all windows in every program—only those in the current program. Option-closing a Microsoft Word document closes all Word windows, but your Finder windows remain open.

Moreover, Option-closing doesn’t work in all programs.

**Minimize Button**

Click this yellow dot to minimize any Mac window, sending it shrinking, with a genie-like animated effect, into the right end of the Dock, where it then appears as an icon. The window isn’t gone. It’s just out of your way for the moment, as though you’ve set it on a shelf. To bring it back, click the newly created Dock icon; see Figure 1-6. Chapter 4 has more on the Dock.

Minimizing is a great window-management tool. In the Finder, minimizing a window lets you see whatever icons were hiding behind it. In a web browser, minimizing lets you hide a window that has to remain open (because you’re waiting for some task to finish) so you can read something else in the meantime.
And now, some Minimize button micro-goodies:

- If you enjoy the ability to roll up your windows in this way, remember that you actually have a bigger target than the tiny Minimize button. You can make the entire title bar a giant Minimize button, as described on page 21.)

Better yet, you can also minimize the frontmost window of almost any program (including the Finder) from the keyboard by pressing ⌘-M. That’s a keystroke worth memorizing on your first day with the Mac.

- Option-clicking one minimized window on the Dock un-minimizes all a program’s windows—at least for Cocoa programs (page 194).

**Tip:** MacOS can change menu commands as you press modifier keys. For example, open a couple of Finder windows and then click the Window menu. Focus on the Minimize Window command. Now press Option and watch both the wording and the listed keyboard equivalent change instantly to Minimize All (Option-⌘-M).

The Option key works wonders on the File menu, too.

- In the bad old days (up to late 2009), minimizing a bunch of documents could get really messy. Each one flew onto the Dock, putting a new icon there, creating a tighter and tighter squeeze, shrinking the Dock’s icons until they were the size of Tic Tacs.

---

Apple has a name for the animation you see when you minimize, open, or close a window: the genie effect, because it so closely resembles the way Barbara Eden, Robin Williams, and other TV and movie genies entered and exited their magic lamps and bottles.

But you don’t have to watch the “genie” animation in precisely the same way, day in and day out. You can slow it down or speed it up, like this:

**Slow it down.** When Steve Jobs first demonstrated Mac OS X, one of his favorite bits was slowing down the animation so we could see it in graceful slow motion. How did he do that?

If you Shift-click a window’s Minimize button, it collapses into the Dock at about one-tenth its usual speed—an effect sure to produce gasps from onlookers. The Shift key also slows the un-minimizing animation, the one you see when you click a window icon in the Dock to restore it to full size.

(Shift-clicking a button to slow down its animation is a running theme on the Mac.)

**Speed it up.** There’s no keystroke for making the animation go faster. You can, however, substitute a faster style of minimizing animation.

To do so, choose System Preferences → Dock. From the “Minimize windows using” pop-up menu, choose Scale Effect, and then close the window. Now, instead of collapsing through an invisible funnel, minimized windows simply shrink as they fly down to the Dock, remaining rectangular. The time you save isn’t exactly going to get you home an hour earlier each day, but at least you have the illusion of greater speed.

(Actually, there’s a third animation style, too, but there’s a trick to unleashing it: You need the free utility called Tinker-Tool. It’s available from this book’s “Missing CD” page at www.missingmanuals.com.)
Nowadays, your document windows can minimize themselves into their program’s Dock icon, rather than creating new Dock icons for themselves. That way, your Dock doesn’t get any more crowded, and the icons on it don’t keep shrinking away to atoms.

To turn on this feature, choose System Preferences → Dock. Turn on “Minimize windows into application icon.”

So how do you get those windows back out of the Dock icon? You use Dock Exposé, which is described on page 197.

**Full Screen Button**

In 2014’s OS X Yosemite, Apple changed the purpose of this third dot, the green one, on every window’s title bar (in most programs, anyway). A click here throws the window into **Full Screen mode**, in which the menu bars and window edges disappear, in the name of making your window fill your screen edge to edge. See page 177 for details.

As your cursor approaches this green dot, a little indicator appears inside it: 🏠. That’s the hint that you’re about to enter Full Screen mode.

And once you’re in Full Screen mode, that shape changes to this: 🏡. That’s right: It’s the universal symbol for “Click me to leave Full Screen mode.”

In OS X versions before Yosemite, this button was called the Zoom button. It made a desktop window just large enough to reveal all the icons inside it (or, in programs, large enough to reveal all the text, graphics, or music). (The Window → Zoom command does the same thing, and so does double-clicking the title bar of a Finder window.)

And if you miss those hazy, happy days, just press the Option key as you click. The button sprouts a 🔖 button, just as it did in the olden days. Now you’ll get a zoomed window instead of a full-screen one. (A second Option-click restores the window to its previous size.)

**Note:** Not all programs permit you to full-screenize their windows. In those apps, this green button displays the 🔖 button and, when clicked, merely zooms the window.

**The Folder Proxy Icon**

In the Finder, there’s a tiny icon next to the window’s name (Figure 1-7). It’s a stand-in—a proxy—for that window’s folder itself.

By dragging this tiny icon, you can move or copy the folder into a different folder or disk, into the Sidebar, into the Trash, or into the Dock without having to first close the window.

**Tip:** You have to hold down the mouse button on the folder proxy icon until the icon darkens before dragging. (It darkens in a fraction of a second.)

When you drag this proxy icon to a different place on the same disk, the usual folder-dragging rules apply: Hold down the Option key if you want to copy the original disk...
or folder; ignore the Option key to move the original folder. (You’ll find details on moving and copying icons in the next chapter.)

Many programs, including Microsoft Word, Preview, TextEdit, and others, offer the same mini-icon in open document windows. Once again, you can use it as a handle to drag a document into a new folder or onto a new disk. Sometimes, doing that really does move the document—but more often you just get an alias of it in the new location.

### The Finder Toolbar

Chapter 4 describes this fascinating desktop-window element in great detail.

#### Two Clicks, One Window

Double-clicking a folder in a window doesn’t leave you with two open windows. Instead, double-clicking a folder makes the contents of the original window disappear (Figure 1-8).

**Tip:** If you Option-double-click a folder, you don’t simply replace the contents of a fixed window that remains onscreen; you actually switch windows, as evidenced by their changing sizes and shapes.

So what if you’ve now opened Inner Folder B, and you want to backtrack to Outer Folder A? In that case, just click the tiny ◀ button—the Back button—in the upper-left corner of the window, or use one of these alternatives:

- Choose Go→Back.
- Press ⌘-[ (left bracket).
- Press ⌘-▲ (up arrow).
• Choose Go→Enclosing Folder.

None of that helps you, however, if you want to move a file from one folder into the other, or to compare the contents of two windows. In that case, you probably want to see both windows open at the same time.

You can open a second window using any of these techniques:

• Choose File→New Finder Window (⌘-N).

### The Go to Folder Command

Sometimes a Unix tentacle pokes through the friendly macOS interface and you find a place where you can use Unix shortcuts instead of the mouse. One classic example is the Go→Go to Folder command (Shift-⌘-G). It brings up a box like the one shown here.

The purpose of this box is to let you jump directly to a certain folder on your Mac by typing its Unix folder path. Depending on your point of view, this special box is either a shortcut or a detour.

For example, if you want to see what’s in the Documents folder of your Home folder, you could choose Go→Go to Folder and type this:

/Users/casey/Documents

Then click Go or press Return. (In this example, of course, casey is your short account name.)

In other words, you’re telling the Mac to open the Users folder in your main hard drive window, then your Home folder inside that, and then the Documents folder inside that. Each slash means “and then open.” (You can leave off the name of your hard drive; that’s implied by the opening slash.) When you press Return, the folder you specified pops open immediately.

Of course, if you really wanted to jump to your Documents folder, you’d be wasting your time by typing all that. Unix (and therefore macOS) offers a handy shortcut that means “home folder.” It’s the tilde character (~) at the upper-left corner of the U.S. keyboard.

To see what’s in your Home folder, then, you could type just that ~ symbol into the Go to Folder box and then press Return. Or you could add some slashes to it to specify a folder inside your Home folder, like this:

~/Documents

You can even jump to someone else’s Home folder by typing a name after the symbol, like this:

~chris

If you get into this sort of thing, here’s another shortcut worth noting: If you type nothing but a slash (/) and then press Return, you jump to the main hard drive window.

Note, too, that you don’t have to type out the full path—only the part that drills down from the window you’re in. If your Home folder window is already open, for example, then you can open the Pictures folder just by typing Pictures.

But Go to Folder really turns into a high-octane timesaver if you use autocompletion. Here’s how it works: After each slash, you can type only enough letters of a folder’s name to give macOS the idea—de instead of desktop, for example—and then wait a fraction of a second (or, if you’re late for a plane, press the Tab key). MacOS instantly and automatically fills in the rest of the folder’s name. It even auto-capitalizes the folder names for you. (In Unix, capitalization matters.)

For example, instead of typing /Applications/Microsoft Office/clipart/standard, you could type nothing more than /ap/mi/cl/st, remembering to press Tab after each pair of letters. Now that’s a way to feel like a Unix programmer.
**Tip:** What folder contents fill the “new” window that appears when you use this command? Usually, it’s the All My Files folder, showing your entire universe of files.

But you can choose any window you want. To make the change, choose Finder→Preferences. Click the General icon. Change the “New Finder windows show” pop-up menu to whatever folder you’d like to use as the starting point for your computing life. All My Files is a good choice; so is your Home folder. But you’re also free to choose your Documents folder, your iDisk, or any folder at all. Now every new Finder window shows you that specified folder, which is a much more useful arrangement.

---

**Figure 1-8:**
To help you avoid window clutter, Apple has designed macOS windows so that double-clicking a folder in a window (top) doesn’t actually open another window (bottom). Every time you double-click a folder in an open window (except in column view), its contents replace whatever was previously in the window. If you double-click three folders in succession, you still wind up with just one open window.

- ⌘-double-click a disk or folder icon.
- Double-click a folder or disk icon on your desktop.
Old Finder Mode

Old Finder Mode (not the official Apple term) was designed for people who came to the Mac from a much older version, like Mac OS 9, and lost half their hair when they discovered how different things were.

In this mode, two of the biggest behavioral differences between macOS and its ancient predecessors disappear:

• The Sidebar and the toolbar blink out of sight.

• Double-clicking a folder now works like it did back in 2000. Every time you double-click a folder, you open a new window for it.

The Old Finder Mode button no longer appears, but the mode itself is still available. Press Option-⌘-T, the equivalent for the View→Hide Toolbar command. (Repeat that keystroke or command to turn Old Finder Mode off again.) This won’t work if your Finder window has multiple tabs open, but that’s not going to be a problem if you’re yearning for the days of yore.

Scroll Bars

On the modern Mac, scroll bars don’t appear nearly as often as they used to. A scroll bar, of course, is the traditional window-edge slider that lets you move through a document that’s too big for the window. Without scroll bars, for example, you’d never be able to write a letter that’s taller than your screen.

On the very first Macs, scroll bars were a necessary evil; those computers were too slow and underpowered to manage visibly moving the contents of the window. That’s why scroll bars were invented in the first place: to give you some feedback about how far you were moving into a document, because the window itself went pure white when you dragged the handle.

Today, though, you can manipulate the contents of a window and see where you are at all times. Nobody questions the absence of scroll bars on an iPad, right? Because you just push the contents of a window around with your fingers to scroll.

How the Scroll Bar Used to Work

If you are that rare, special individual who still operates the scroll bar by clicking it with the mouse, the old-style controls are still around.

For example: Ordinarily, when you click in the scroll bar track above or below the dark-gray handle bar, the window scrolls by one screenful. But another option awaits when you choose System Preferences→General and turn on “Jump to the spot that’s clicked.” Now when you click the scroll-bar track, the Mac considers the entire scroll bar a proportional map of the document and jumps precisely to the spot you clicked. That is, if you click the very bottom of the scroll-bar track, you see the very last page.

No matter which scrolling option you choose in the Appearance panel, you can always override your decision on a case-by-case basis by Option-clicking the scroll-bar track. In other words, if you’ve selected the “Jump to the spot that’s clicked” option, you can produce a “Jump to the next page” scroll by Option-clicking in the scroll-bar track.
In macOS, you scroll by pushing two fingers up the trackpad (or one finger up the Magic Mouse) or by turning your mouse’s scroll wheel. You almost never use the antiquated method of dragging the scroll bar’s handle manually, with the mouse.

**Tip:** You can also scroll using the keyboard. Your Page Up and Page Down keys let you scroll up and down, one screen at a time, without having to take your hands off the keyboard. The Home and End keys are generally useful for jumping directly to the top or bottom of your document (or Finder window). And, if you’ve bought a mouse that has a scroll wheel on the top, you can use it to scroll windows without pressing any keys at all.

That’s a long-winded way of explaining why, in most programs, the scroll bars are hidden. See Figure 1-9 for details.

**Note:** If the missing scroll bars leave you jittery and disoriented, you can bring them back. Open System Preferences → General and then turn on “Show scroll bars: Always.”

**Figure 1-9:** Scroll bars don’t appear at all while you’re working (right); you have more screen area dedicated to your work. If you begin to scroll by sliding your fingers across the trackpad or Magic Mouse, the scroll-bar handle appears, so you know where you are (middle).

At that point, if you point to the scroll bar, it fattens up so you can grab it (left).

**Resizable Edges**

For the first 28 years of its existence, the Mac offered only one way to make a window bigger or smaller: Drag the ribbed-looking lower-right corner. These days, you can drag any edge of a window to change its shape. Just move the pointer carefully to the exact top, bottom, left, or right edge; once the pointer changes to a double-headed arrow, you can drag to move that window’s edge in or out.

**Tip:** There are a few cool, totally undocumented variations on the window-edge-dragging business. First, if you press the Option key while dragging, you resize the opposite edge simultaneously. For example, if you Option-drag the bottom edge upward, the top edge simultaneously collapses downward. If you press Shift as you drag, you resize the entire window, retaining its proportions. And if you Shift-Option drag, you resize the window around its center, rather than from its edges.
Insta–Full Screen

But why drag a window manually? That’s so—2015! In macOS Sierra, you can let the software do the dragging for you.

Turns out that if you *double-click* any edge of a window, it snaps to the full width of your screen in that direction: left, right, top, or bottom (see Figure 1-10).

*Figure 1-10:*

Top: Suppose you’ve got a window. Hey—it could happen. You double-click the right edge of it, and boom: You’ve extended the window all the way to the right edge of the screen (middle).

Bottom: If you press Option at the time, you extend the window all the way to both edges of the screen. This feature works in Apple’s own programs (Finder, Mail, TextEdit, and so on), but not in programs that have their own weird ways of doing things (Microsoft Word, for example).
And if you double-click any edge while pressing Option, the window expands to the full height or width of the monitor in both directions (Figure 1-10, bottom).

**Snappable Windows**

Here’s a new macOS Sierra feature that Apple completely forgot to mention: It’s now much easier to position windows tightly against each other, side by side, for comparison or copying. As you slowly drag a window (by its title bar, for example), you’ll notice that its edge *sticks* momentarily to any other window edge it passes.

This feature works only in Apple’s own programs—and it doesn’t happen if you’re dragging quickly.

**Tip:** If you’re pressing the Option key as you drag, you eliminate that moment of stickiness. Use this trick when you’re in a real, real hurry.

**Path Bar**

Choose View→Show Path Bar to see a tiny map at the bottom of the window, showing where you are in the folder hierarchy. If it says Casey→Pictures→Picnic, well, then, by golly, you’re looking at the contents of the Picnic folder, which is inside Pictures, which is inside your Home folder (assuming your name is Casey).

**Tip:** Each tiny folder icon in this display is fully operational. You can double-click it to open it, right-click or two-finger click it to open a shortcut menu, or even drag things into it.

**Status Bar**

MacOS hides yet another information strip at the bottom of a window: the status bar, which tells you how many icons are in the window (“14 items,” for example) and the free space remaining on the disk. To make it appear, choose View→Show Status Bar.

**Tip:** The status bar shows you disk-space information for the entire disk, but not how much disk space *this particular window’s* contents occupy.

To find out *that* piece of information, make sure no icon in the window is highlighted. Then choose File→Get Info (or press ⌘-I). The resulting Info window, which is described starting on page 96, shows the size of the folder or disk whose window you’re browsing, along with other useful statistics.

**The Four Window Views**

You can view the files and folders in a desktop window in any of four ways: as icons; as a single, tidy list; in a series of neat columns; or in Cover Flow view, where you can flip through giant document icons like they’re CDs in a music-store bin. Figure 1-11 shows the four views.

Every window remembers its view settings independently. You might prefer to look over your Applications folder in list view (because it’s crammed with files and folders)
but view the Pictures folder in icon or Cover Flow view, where the larger icons serve as previews of the photos.

To switch a window from one view to another, just click one of the four corresponding icons in the window’s toolbar (Figure 1-11).

You can also switch views by choosing View→as Icons (or View→as Columns, or View→as List, or View→as Cover Flow), which can be handy if you’ve hidden the toolbar. Or, for less mousing and more hard-bodied efficiency, press ⌘-1 for icon view, ⌘-2 for list view, ⌘-3 for column view, or ⌘-4 for Cover Flow view.

Or, if your Mac has a Touch Bar, you can install a Views button onto it (page 237).

The following pages cover each of these views in greater detail.
Note: One common thread in the following discussions is the availability of the View Options palette, which lets you set up the sorting, text size, icon size, and other features of each view, either one window at a time or for all windows.

Apple gives you a million different ways to open View Options. You can choose View→Show View Options, or press Option-J, or choose Show View Options from the ⌘ menu at the top of every window.

**Icon View**

In icon view, every file, folder, and disk is represented by a small picture—an icon. This humble image, a visual representation of electronic bits and bytes, is the cornerstone of the entire Mac religion. (Maybe that’s why it’s called an icon.)

**Icon Size**

MacOS draws those little icons using sophisticated graphics software. As a result, you can scale them to almost any size without losing quality or clarity. If you choose View→Status Bar so that the bottom-edge strip shown in Figure 1-12 appears, you get a size slider that you can drag to the right or left to make that window’s icons larger or smaller. (For added fun, make little cartoon sounds with your mouth.)

---

**Figure 1-12:**

Once you make the status bar appear, you can choose an icon size to suit your personality. For picture folders, it can often be very handy to pick a jumbo size, in effect creating a slide-sorter “light table” effect. Icons can be an almost ridiculously large 512 pixels square.
Icon Previews

The Mac expands the notion that “an icon is a representation of its contents” to an impressive extreme. As you can see in Figure 1-13, each icon actually looks like a miniature of the first page of the real document.

Because you can make icons so enormous, you can actually watch movies, or read PDF and text documents, right from their icons.

To check out this feature, point to an icon without clicking. A Play button (►) appears on any movie or sound file; as shown in Figure 1-13, ◀ and ▶ page buttons appear on multipage documents (like PDF, Pages, or even presentation documents like PowerPoint and Keynote). You can actually page through one of these documents right there on its icon without having to open the program!

Figure 1-13: You can page through PDF and presentation icons, or play movies and sounds, right on their icons. (Movie icons even display a circular progress bar so you know how far you are into the video.)

Multiple Views, Same Folder

If you’ve read this chapter carefully, you may have discovered a peculiar quirk of the macOS Finder: By choosing FileÆNew Finder Window (or double-clicking a disk or folder icon), you open a second, completely independent Finder window. Therefore, if you stop to think about it, there’s nothing to stop you from opening a third, fourth, or fifth copy of the same folder window. Once they’re open, you can even switch them into different views.

Try this, for example: Choose GoÆApplications. Choose FileÆNew Finder Window ( ), and then choose GoÆApplications again. Using the View menu or the controls in the toolbar, put one of these windows into list view and the other into icon view.

This ability has its advantages. For example, you might decide to open the same window twice while doing some hard-drive housekeeping. By keeping a list view open, you can check the Size column as you move your files into different folders (so you can make sure the folders fit onto a blank CD, for example). By keeping a column view open, on the other hand, you gain quicker navigational access to the stuff on your drive.
**Tip:** If you Option-click the little « and » buttons on a PDF, PowerPoint, or Keynote icon preview, you jump to the first or last page or slide in the document.

**Icon-View Options**

MacOS offers a number of useful icon-view options, all of which are worth exploring. Start by opening any icon-view window, and then choose View→Show View Options (⌘-J). (You can put a View Options button onto your Touch Bar, if you have one, too; see page 237.)

The dialog box shown in Figure 1-14 appears.

![Figure 1-14: Drag the “Grid spacing” slider to specify how tightly packed you want your icons to be. At the minimum setting, they’re so crammed it’s almost ridiculous; you may not even be able to see their full names. But sometimes you don’t really need to. At a more spacious setting (bottom), you get a lot more white space.](image)

**Always open in icon view**

It’s easy—almost scarily easy—to set up your preferred look for all folder windows on your entire system. With one click on the Use as Defaults button (described on page 39), you can change the window view of 20,000 folders at once—to icon view, list view, or whatever you like.
The “Always open in icon view” option lets you override that master setting, just for one window.

For example, you might generally prefer a neat list view with large text. But for your Pictures folder, it probably makes more sense to set up icon view, so you can see a thumbnail of each photo without having to open it.

That’s the idea here. Open Pictures, change it to icon view, and then turn on “Always open in icon view.” Now every folder on your Mac is in list view except Pictures.

**Note:** The wording of this item in the View Options dialog box changes according to the view you’re in at the moment. In a list-view window, it says “Always open in list view.” In a Cover Flow–view window, it’s “Always open in Cover Flow.” And so on. But the function is the same: to override the default (master) setting.

**Browse in icon view**

This option makes sure that any folders inside the current window open up into icon view, too, even if you’d previously set them to open into some other view. So if you’re looking at your Pictures folder in icon view and you open the Grand Canyon Jaw-Droppers folder inside it, that folder also will be in icon view.

**Arrange By, Sort By**

For a discussion of these pop-up menus, see page 39.

**Icon size**

It’s super-easy to make all your icons bigger or smaller; just drag the Icon Size slider in the lower-right corner of the window.

But for the benefit of old-timers who expect to find that slider in the View Options window, well, there’s an identical slider there.

**Grid spacing**

Listen up, whippersnappers! When I was your age, back when computers used Mac OS 9, you could control how closely spaced icons were in a window. Why, if I wanted to see a lot of them without making the window bigger, I could pack ’em in like sardines!

That feature disappeared—for seven years. But in Mac OS X 10.5, it returned. Figure 1-14 shows all.

**Text size**

Your choices range only from 10 to 16 points, and you can’t choose a different font for your icons’ names. But using this pop-up menu, you can adjust the type size. And for people with especially big or especially small screens—or for people with aging retinas—this feature is much better than nothing.

In fact, you can actually specify a different type size for every window on your machine. (Why would you want to adjust the point size independently in different windows? Well, because you might want smaller type to fit more into a crammed list view without scrolling, while you can afford larger type in less densely populated windows.)
**Label position**

Click either Bottom or Right to indicate where you want an icon’s name to appear, relative to its icon. As shown in Figure 1-15 at bottom, this option lets you create, in effect, a multiple-column list view in a single window.

![Figure 1-15: The View Options for an icon-view window let you create colored backgrounds (top) or even use photos as window wallpaper (bottom). Using a photo may have a soothing, comic, or annoying effect—like making the icon names completely unreadable. (Note, by the way, how the icons’ names have been set to appear beside the icons, rather than underneath, in the lower illustration. You now have all the handy, freely draggable convenience of an icon view, along with the more compact vertical spacing of a list view.)](image)

**Show item info**

While you’ve got the View Options palette open, try turning on “Show item info.” Suddenly you get a new line of information (in tiny blue type) for certain icons, saving you the effort of opening up the folder or file to find out what’s in it. For example:

- **Folders.** The info line lets you know how many icons are inside each without having to open it up. Now you can spot empties at a glance.

- **Graphics files.** Certain other kinds of files may show a helpful info line, too. For example, graphics files display their dimensions in pixels.

- **Sounds and QuickTime movies.** The light-blue bonus line tells you how long the sound or movie takes to play. An MP3 file might say “03’ 08” (3 minutes, 8 seconds).

- **.zip files.** On compressed archives like .zip files, you get to see an archive’s total size on disk (like “48.9 MB”).

---

**CHAPTER 1: FOLDERS, WINDOWS & FINDER TABS**
Show icon preview
This option is what makes icons display their contents, as shown in Figure 1-12. If you turn it off, then icons no longer look like miniature versions of their contents (tiny photos, tiny PDF files, and so on). Everything takes on generic icons.

You might prefer this arrangement when, for example, you want to be able to pick out all the PDF files in a window full of mixed document types. Thanks to the matching icons, it’s easy now.

Background
Here’s a luxury that other operating systems can only dream about: You can fill the background of any icon-view window on your Mac with a certain color—or even a photo.

Color coordinating or “wallpapering” certain windows is more than just a gimmick. In fact, it can serve as a timesaving visual cue. Once you’ve gotten used to the fact that your main Documents folder has a sky-blue background, you can look at a screen filled with open windows and pick it out like a sharpshooter. Color-coded Finder windows are also especially easy to distinguish at a glance when you’ve minimized them to the Dock.

Note: Background colors and pictures show up only in icon view.

Once a window is open, choose View→View Options (⌘-J). The bottom of the resulting dialog box offers three choices.

• White. This is the standard option.

• Color. When you click this button, you see a small rectangular button beside the word “Color.” Click it to open the Color Picker, which you can use to choose a new background color for the window (Figure 1-15, top). Unless it’s April Fools’ Day, pick a light color. If you choose a dark one—like black—you won’t be able to make out the lettering of the icons’ names.

• Picture. If you choose this option, a “Drag image here” square appears. Now find a graphics file—one of Apple’s in the Desktop Pictures folder, or one of your own, whatever—and drag it into that “well.”

When you click Select, you see that macOS has superimposed the window’s icons on the photo. As you can see in Figure 1-15, bottom, low-contrast or light-background photos work best for legibility.

Incidentally, the Mac has no idea what sizes and shapes your window may assume in its lifetime. Therefore, it makes no attempt to scale down a selected photo to fit neatly into the window. If you have a high-res digital camera, therefore, you may see only the upper-left corner of your photo in the window. For better results, use a graphics program to scale the picture down to something smaller than your screen resolution.
**Use as Defaults**
This harmless-looking button can actually wreak havoc on your kingdom—or restore order to it—with a single click. It applies the changes you’ve just made in the View Options dialog box to all icon-view windows on your Mac (instead of only the frontmost window).

If you set up the frontmost window with a colored background, big icons, small text, and a tight grid, and then you click Use as Defaults, you’ll see that look in every disk or folder window you open.

You’ve been warned.

Fortunately, there are two auxiliary controls that can give you a break from all the sameness:

- First, you can set up individual windows to be weirdo exceptions to the rule; see page 35.

- Second, you can remove any departures from the default window view—after a round of disappointing experimentation on a particular window, for example—using a secret button. Choose View → Show View Options to open the View Options dialog box. Now hold down the Option key. The Use as Defaults button magically changes to Restore to Defaults, which means “Abandon all the changes I’ve foolishly made to the look of this window.”

**Tip:** In the View Options for your Home folder, a checkbox appears: Show Library Folder. The Library folder is usually hidden, to prevent clueless newbies from wreaking havoc on important files. But macOS is willing to give it back to you—if you know about this sneaky little trick.

**Arrange By and Sort By**
You can wield two different kinds of control over the layout of files in a Finder window: arranging and sorting.

**Tip:** You can perform all these obsessive reorganizations in any view: icon view, list view, column view, or Cover Flow view. That’s a big change from the olden days.

**Arranging**
Arranging files means “Put my files into related clumps, separated by headings that identify them.” You can arrange files in any of the views—icon, list, column, Cover Flow—and there are some incredibly useful options here.

For example, you can arrange your documents into application groups (meaning which program opens each one); now you can see at a glance which files will open in, say, iTunes when you double-click them. Or you can organize your Pictures folder into Date Added groups, with headings like “Today,” “Last 7 Days,” and “Earlier.”
Figure 1-16 shows a few examples.

**Tip:** In icon view, the icons under each heading appear in a single row, scrolling off endlessly to the right. Use the usual sideways-scrolling gesture to flip through a row. (That is, swipe to the left on a trackpad with two fingers, or with one finger on a Magic Mouse.)

If you’re not into gestures, or if you don’t have a swipeable input device, then click the tiny Show All button at the right end of a row. Now you’ve turned off that one-row-per-heading thing, and all the icons under that heading appear in the usual rows and columns; scroll down to see them all.

Apple wants to make extra, extra sure you’re aware of the Arrange commands. It gives you four different ways to find them:

- **Choose View→Arrange By.** Choose one of the criteria from the submenu. Your options are Name (alphabetically); Kind (type of file, like Images, Movies, and Documents); Application (which program opens which documents); Date (Last Opened, Added [to the window], Modified, or Created); Size; or Tags (Finder Tag colors, described on page 88). Marvel as the Finder puts your files into tidy categorized groups.
Note: When you’re looking at the Applications folder, you get a special choice: Application Category. It clumps your programs by what they do: Productivity, Social Networking, Music, Video, Board Games, Entertainment, Utilities, Reference, Photography, and so on. Pretty cool, actually.

- Choose from the icon. This icon appears in the toolbar of every Finder window. It contains the same options listed in the previous bullet.

- Right-click or two-finger click an empty spot in an icon-view window; choose from the Arrange By shortcut menu. Yep, it’s those same commands again.

- In the View Options palette (seen in Figure 1-14), use the Arrange By pop-up menu. Yes, it’s a fourth place to find the same six options.

Note: In each case, you can choose None to turn off the grouping altogether.

Remember, arranging (clumping) is not sorting. You can, in fact, sort the icons differently within each arranged group; read on.

Sorting

Sorting means just what it says (except that it used to be called “arranging”): You can sort your files alphabetically (by Name), chronologically (by Date), in order of hugeness (by Size), and so on. See Figure 1-17.

You can sort a window whether or not you’ve also arranged (grouped) it. You can even sort by different criteria. For example, you might have the programs in your Applications folder arranged by Application Category but sorted alphabetically within each category.
Once again, Apple gives you four ways to sort:

- **While pressing the Option key, choose View→Sort By.** (Pressing Option turns the Arrange By submenu into the Sort By submenu.) Choose one of the criteria: Name, Size, and so on.

- **While pressing the Option key, click the 📚 icon.** Once again, the Option key turns the Arrange By options into Sort By options.

- **Right-click (or two-finger click) an empty spot in an icon-view window.** **Press the Option key.** And again Option turns the Arrange By options into Sort By options.

- **In the View Options palette, use the Sort By pop-up menu.** Hey, guess what? You didn’t have to press the Option key this time.

**Tip:** In icon view, you get an additional option: Snap to Grid. It means “Let me drag these icons into any sequence I want, using the trackpad or mouse.” When you release each drag, the icon jumps into the nearest position on the underlying spacing grid (unless you press the ⌘ key, which gives you full manual control over the icon’s position).

This option appears only if Arrange By is set to None. After all, if you’ve asked the Mac to arrange your icons into groups, then you’ve relinquished control of their grid spacing.

**Free dragging—and grid spacing**

Whenever you’ve applied an Arrange or a Sort to an icon view, the icons remain rooted to an invisible underlying rows-and-columns grid. You can’t budge them.

**Tip:** You can, however, control how tight or loose that grid is, using the “Grid spacing” slider described on page 35.

But there are two situations when you’re allowed to drag icons freely into any order you want:

- **Icons never snap to the grid.** If both Arrange By and Sort By are set to None, then you can go nuts, freely dragging icons into sloppy, off-the-grid positions.

  If, later, you become overwhelmed by shame at your untidiness, you can choose View→Clean Up (if nothing is selected) or View→Clean Up Selection (if some icons are highlighted). Now all icons in the window, or those you’ve selected, jump to the closest positions on the invisible underlying grid.

  These same commands appear in the shortcut menu when you right-click or two-finger click anywhere inside an icon-view window, which is handier if you have a huge monitor.

  (There’s even a Clean Up By submenu in the View menu and the shortcut menu. These commands don’t just put icons back onto the closest grid positions; they put the icons into their proper sorted positions among the other icons—by name, size, date, and so on.)
Tip: If you press Option, then the Mac swaps the wording of the command. Clean Up changes to Clean Up Selection, and vice versa.

- Icons always snap to the grid. If Arrange By is set to None but Sort By is set to Snap to Grid, then you can drag icons into any order you like (that is, not in any particular sorted order)—but they’ll snap to the grid when you let go of the mouse button.

Tip: If you press the ⌘ key as you release the drag, you can reverse the snapping logic. That is, the icons will snap to the grid if Sort By is set to None, but you can drag them freely if it’s set to Snap to Grid. (Don’t press the key until after you’ve begun to drag.)

Although it doesn’t occur to most people, you can also apply any of the commands described in this section—Clean Up, Arrange, Sort—to icons lying loose on your desktop. Even though they don’t seem to be in any window at all, you can specify small or large icons, automatic alphabetical arrangement, and so on. Just click the desktop before using the View menu or the View Options dialog box.

Note: There’s only one View Options dialog box. Once it’s open, you can adjust the icon sizes or arrangement options of other windows just by clicking them. Each time you click inside a window, the View Options dialog box remains in front, changing to reflect the settings of the window you just clicked.

Incidentally, you can get rid of the View Options box the same way you summoned it: by pressing ⌘-J.

List View

In windows that contain a lot of icons, list view is a powerful weapon in the battle against chaos. It shows you a tidy table of your files’ names, dates, sizes, and so on (Figure 1-18).

You get to decide how wide your columns should be, which of them should appear, and in what order (except that Name is always the first column). Here’s how to master these columns.

Sorting the List

Most of the world’s list-view fans like their files listed alphabetically. It’s occasionally useful, however, to view the newest files first, largest ones first, or whatever.

When a desktop window displays its icons in list view, a convenient strip of column headings appears. These headings aren’t just signposts; they’re buttons, too. Click Name for alphabetical order, Date Modified to view the newest first, Size to view the largest files at the top, and so on.

Don’t miss the tiny ▲ or ▼ that appears in the column you’ve most recently clicked. It shows you which way the list is being sorted. When it’s ▲, then the oldest files, smallest files, or files beginning with numbers (or the letter A) appear at the top of the list, depending on which sorting criterion you selected.
**Tip:** It may help you to remember that when the smallest portion of the triangle is at the top (\(^\wedge\)), the smallest files are listed first when viewed in size order.

To reverse the sorting order, click the column heading a second time. Now the \(\_\) shows you that the newest files, largest files, or files beginning with the letter Z appear at the top of the list.

![Figure 1-18: You control the sorting order of a list view by clicking the column headings (top). Click a second time to reverse the sorting order (bottom). You’ll find the \(\_\) or \(\_\) triangles—indicating the identical information—in email programs, iTunes, and anywhere else where reversing the sorting order of a list can be useful.](image)

**Note:** You can also change the sorting order using the Sort By command described earlier (in the View menu, the \(\_\_\) pop-up menu, or the View Options dialog box). But, honestly, clicking the column headings is much faster.
Arranging the List
You can arrange your list view into groups by name, date, kind, and so on, with tidy headings that help you make sense of it all. This unsung feature is described under “Arrange By and Sort By” on page 39.

Flippy Triangles
One of the Mac’s most attractive features is the tiny triangle that appears to the left of a folder’s name in a list view.

In its official documents, Apple calls these buttons disclosure triangles; internally, the programmers call them flippy triangles. (They don’t appear if you’ve sorted the window using the View→Arrange By menu.)

When you click one, the list view turns into an outline, showing the contents of the folder in an indented list, as shown in Figure 1-19. Click the triangle again to collapse the folder listing. You’re saved the trouble and clutter of opening a new window just to view the folder’s contents.

By selectively clicking flippy triangles, you can in effect peer inside two or more folders simultaneously, all within a single list-view window. You can move files around by dragging them onto the tiny folder icons.

GEM IN THE ROUGH

Flippy Triangle Keystrokes

The keystrokes that let you open and close flippy triangles in a list view are worth committing to memory.

First, pressing the Option key when you click a flippy triangle lets you view a folder’s contents and the contents of any folders inside it. The result, in other words, is a longer list that may involve several levels of indentation.

If you prefer to use the keyboard, then substitute ▶ (to expand a selected folder’s flippy triangle) or ◄ (to collapse the folder listing again). Here again, adding the Option key expands or collapses all levels of folders within the selected one.

Suppose, for example, that you want to find out how many files are in your Pictures folder. The trouble is, you’ve organized your graphics files within that folder in several category folders. And you realize that the “how many items” statistic in the status bar shows only how many icons are visible in the window. In other words, you won’t know your total photo count until you’ve expanded all the folders within the Pictures folder.

You could perform the entire routine from the keyboard like this: Get to your Home folder by pressing Shift-Control-H. Select the Pictures folder by typing the letter P. Open it by pressing Control-O (the shortcut for File→Open) or Command-Return. Switch to list view, if necessary, with a quick Command-2. Highlight the entire contents by pressing Command-A (short for Edit→Select All).

Now that all folders are highlighted, press Option-►. You may have to wait a moment for the Mac to open every subfolder of every subfolder. But, eventually, the massive list appears, complete with many levels of indentation. At last, the “items” statistic in the status bar gives you a complete, updated tally of how many files and folders, combined, are in the window.
**Tip:** Once you’ve expanded a folder by clicking its flippy triangle, you can even drag a file icon out of the folder so that it’s loose in the list-view window. To do so, drag it directly upward onto the column headings area (where it says Name, for example). When you release the mouse, you see that the file is no longer inside the expanded folder.

**Figure 1-19:** Click a “flippy triangle” (left) to see the list of the folders and files inside that folder (right). Or press the equivalent keystrokes: ‹ (to open) and › (to close).

---

**Your Choice of Columns**

Choose View→Show View Options. In the dialog box that appears, you’re offered on/off checkboxes for the different columns of information macOS can show you, as illustrated in Figure 1-20:

- **iCloud Status.** This checkbox is dimmed for every folder except what’s in your iCloud Drive folder (page 221). If you turn it on, you’ll get a column that indicates whether or not each file has been downloaded from iCloud to your Mac.

- **Date Modified.** This date-and-time stamp indicates when a document was last saved. Its accuracy, of course, depends on the accuracy of your Mac’s built-in clock.

  **Note:** Many an up-to-date file has been lost because someone spotted a very old date on a folder and assumed that the files inside were equally old. That’s because the modification date shown for a folder doesn’t reflect the age of its contents. Instead, the date on a folder indicates only when items were last moved into or out of that folder. The actual files inside may be much older, or much more recent.

- **Date Created.** This date-and-time stamp shows when a document was *first* saved.

- **Date Added.** This option shows when a file was added to this folder or window.
• **Size.** With a glance, you can tell from this column how much disk space each of your files and folders is taking up in kilobytes, megabytes, gigabytes, or terabytes—whichever the Mac thinks you’ll find most helpful.

**Tip:** For disks and folders, you see only a dash—at first. You can, however, instruct the Mac to reveal their sizes, as described on page 49.

---

**Figure 1-20:**
The checkboxes you turn on in the View Options dialog box determine which columns of information appear in a list-view window. Many people live full and satisfying lives with only the three default columns—Date Modified, Kind, and Size—turned on. But the other columns can be helpful in special circumstances; the trick is knowing what information appears there.

---

• **Kind.** In this column, you can read what kind of file each icon represents. You may see, for example, Folder, JPEG Image, Application, and so on.

• **Version.** This column displays the version numbers of your programs. For folders and documents, you just see a dash.

• **Comments.** This rarely seen column (Figure 1-21) can actually be among the most useful. Suppose you’re a person who uses the Comments feature (highlight an icon, choose File→Get Info, type notes about that item into the Spotlight Comments box). This column displays the first line of those comments about each icon, which comes in handy when tracking multiple versions of your documents.

• **Tag.** Tags are colors and identifying phrases that you can slap onto icons, wherever they appear, to help you categorize and group them. For details, see page 88.

Even with this column turned off, you can still see an icon’s color, of course. But only by turning on this column do you get to see the text phrase you’ve associated with each label.
**Other View Options**

The View Options for a list view include several other useful settings; choose View→Show View Options or press ⌘-J.

- **Always open in list view.** Turn on this option to override your system-wide preference setting for all windows. See page 35 for details.

- **Browse in list view.** Ensures that any folder inside this one will also open up in list view, even if its regularly scheduled view is something else.

  ![Figure 1-21:](image)

  *Figure 1-21: If your monitor is big enough, you can expand the Comments column to show several paragraphs, all in a single line—enough to reveal the full life history of each icon. (To enter some comments about an icon, type into the Spotlight Comments box in its Get Info, as shown here at bottom.)*

- **Icon size.** These two buttons offer you a choice of icon sizes for the current window: either standard or tiny. Unlike icon view, list view doesn’t give you a size slider.

  Fortunately, even the tiny icons aren’t so small that they show up blank. You still get a general idea of what they’re supposed to look like.

- **Text size.** You can change the type size for your icon labels, either globally or one window at a time.

- **Show columns.** Turn on the columns you’d like to appear in the current window’s list view, as described in the previous section.

- **Use relative dates.** In a list view, the Date Modified, Date Added, and Date Created columns generally display information in a format like this: “Sunday, March 5, 2017.” (The Mac uses shorter date formats as the column gets narrower.) But when the “Use relative dates” option is turned on, it substitutes the words “Yesterday” or “Today” where appropriate, making recent files easier to spot.

- **Calculate all sizes.** See the box on the facing page.
• **Show icon preview.** Exactly as in icon view, this option turns the icons of graphics files into miniatures of the photos or images within.

• **Use as Defaults.** Click to make your changes in the View Options box apply to all windows on your Mac. (Option-click this button to restore a wayward window back to your defaults.)

**Rearranging Columns**

You’re stuck with the Name column at the far left of a window. However, you can rearrange the other columns just by dragging their gray column headers horizontally. If the Mac thinks you intend to drop a column to, say, the left of the column it overlaps, you’ll actually see an animated movement—indicating a column reshuffling—even before you release the mouse button.

**Adjusting Column Widths**

If you place your cursor carefully on the dividing line between two column headings, you’ll find that you can drag the divider line horizontally. Doing so makes the column to the left of your cursor wider or narrower.

---

**FREQUENTLY ASKED QUESTION**

**Calculate All Sizes**

*When I sort my list view by size, I see only dashes for folder sizes. What am I doing wrong?*

Nothing at all; that’s normal. When viewing a Finder window, you see a Size statistic for each file. For folders and disks, however, you’re shown only an uninformative dash.

Most Mac fans study this anomaly momentarily, scratch their chins, and then get back to their work. Former Windows people don’t even scratch their chins; Windows PCs never show folder-size or disk-size information in list views.

Here’s what’s going on: It can take a computer a long time to add up the sizes of all files inside a folder. Your System → Library folder alone, for example, contains over 100,000 files. Instead of making you wait while the Mac does all the addition, macOS simply shows you a dash in the folder’s Size column.

On occasion, however, you really do want to see how big your folders are. In such cases, choose View → Show View Options and turn on “Calculate all sizes.” You see the folder sizes slowly begin to pop onto the screen, from the top of the window down, as the Mac crunches the numbers on the files within. (You’ll know that the crunching is still in progress, because you’ll see the size statistics for some icons appear in light gray. That’s the Mac’s way of saying, “I’m not totally sure about this folder’s size yet.”)

In fact, you can even turn on the “Calculate all sizes” option _globally_—that is, for all windows. In operating systems of days gone by, this act would have caused a massive slowdown of the entire computer. But macOS is multithreaded; it has the opposite of a one-track mind. It’s perfectly capable of devoting all its attention to calculating your folder sizes and to whatever work you’re doing in the foreground.

Now consider this anomaly: Suppose you’ve opted to sort a particular window by folder size—in other words, you’ve clicked Size at the top of the column. Turning on “Calculate all sizes” bewilders the unprepared, as folders arbitrarily begin leaping out of order, forcing the list to rearrange itself a couple of times per second.

What’s happening, of course, is that all folders begin at the bottom of the list, showing only dashes in the Size column. Then, as the Mac computes the size of your folders’ contents, they jump into their correct sorted order at what may seem to be random intervals.
What’s delightful about this activity is watching macOS scramble to rewrite its information to fit the space you give it. For example, as you make the Date Modified (or Created) column narrower, “Wednesday, March 8, 2017, 2:22 PM” shrinks first to “Wed, Mar 8, 2017, 2:22 PM,” then to “3/8/17, 2:22 PM,” and finally to a terse “3/8/17.”

If you make a column too narrow, macOS shortens the file names by removing text from the middle. An ellipsis (…) appears to show you where the missing text would have appeared. (Apple reasoned that truncating the ends of file names, as in some other operating systems, would hide useful information, like the numbers at the end of “Letter to Marge 1,” “Letter to Marge 2,” and so on. It would also hide the three-letter extensions, such as Thesis.doc, that may appear on file names in macOS.)

For example, suppose you’ve named a Word document “Justin Bieber—A Major Force for Righteousness and Cure for Depression, Acne, and Migraine Headache.” (Yes, file names really can be that long.) If the Name column is too narrow, though, you might see only “Justin Bieber—A Major…Migraine Headache.”

**Tip:** You don’t have to make the column mega-wide to read the full text of a file whose name has been shortened. Just point to the icon’s name without clicking. After a moment, a floating balloon appears—something like a tooltip in Microsoft programs—to identify the full name.

In fact, you can move your mouse up or down a list over truncated file names, and their tooltip balloons appear instantaneously. (This trick works in list, column, or Cover Flow views—and in Save and Open dialog boxes, for that matter.)

### Column View

The goal of column view is simple: to let you burrow down through nested folders without leaving a trail of messy, overlapping windows in your wake.

The solution is shown in Figure 1-22. It’s a list view that’s divided into several vertical panes. The first pane (not counting the Sidebar) shows whatever disk or folder you first opened.

When you click a disk or folder in this list (once), the second pane shows a list of everything in it. Each time you click a folder in one pane, the pane to its right shows what’s inside. The other panes slide to the left, sometimes out of view. (Use the horizontal scroll bar to bring them back.) You can keep clicking until you’re looking at the file icons inside the most deeply nested folder.

If you discover that your hunt for a particular file has taken you down a blind alley, it’s not a big deal to backtrack, since the trail of folders you’ve followed to get here is still sitting before you on the screen. As soon as you click a different folder in one of the earlier panes, the panes to its right suddenly change, so that you can burrow down a different rabbit hole.

The beauty of column view is that, first of all, it keeps your screen tidy. It effectively shows you several simultaneous folder levels but contains them within a single window.
With a quick ⌘-W, you can close the entire window, panes and all. Second, column view provides an excellent sense of where you are. Because your trail is visible at all times, it’s much harder to get lost—wondering what folder you’re in and how you got there—than in any other window view.

*Figure 1-22: If the rightmost folder contains pictures, sounds, Office documents, or movies, you can look at them or play them right there in the Finder. You can drag this jumbo preview icon anywhere—into another folder or to the Trash, for example.*

**Column View by Keyboard**

Efficiency fans can operate this entire process by keyboard alone. For example:

• You can jump from one column to the next by pressing the ⬅ or ➤ keys.

• You can use the Go menu, or the icons in the Sidebar, to fill your columns with the contents of the corresponding folder—Home, Favorites, Applications, and so on.

• The Back command (clicking the ⏪ button on the toolbar, pressing ⌘-[, or choosing Go→Back) works as it does in a web browser: It retraces your steps backward. Once you’ve gone back, in fact, you can then go forward again; choose Go→Forward, or press ⌘-].

• Within a highlighted column, press the ▲ or ▼ keys to highlight successive icons in the list. Or type the first couple of letters of an icon’s name to jump directly to it.

• When you finally highlight the icon you’ve been looking for, press ⌘-O or ⌘- ▼ to open it (or double-click it, of course). You can open anything in any column; you don’t have to wait until you’ve reached the rightmost column.

**Manipulating the Columns**

The number of columns you can see without scrolling depends on the width of the window. That’s not to say, however, that you’re limited to four columns (or whatever
fits on your monitor). You can make the columns wider or narrower—either individually or all at once—to suit the situation, according to this scheme:

- **To make a single column wider or narrower**, drag the fine vertical line that separates it from the column to its right (see Figure 1-23). To adjust all the columns simultaneously, press the Option key as you drag one of the divider lines.

- **To make a column precisely as wide as necessary** to reveal all the names of its contents, double-click the divider line on its right side.

- **To make all columns as wide as required**—when you absolutely, positively don’t want any names truncated—Option-double-click a column’s right-side divider line.

**Tip:** If you’re having trouble remembering all those key and click combinations, you’re not alone. Fortunately, you can use a right-click trick instead.

If you right-click or two-finger click the divider line at the right side of a column, you get a shortcut menu that offers these commands: Right Size This Column (make it exactly as wide as necessary), Right Size All Columns Individually (make every column exactly as wide as necessary), and Right Size All Columns Equally (make all columns the same width, based on whatever width is necessary to see all the names in the narrowest one).

### Grouping the Column Contents

Yes, the Arrange commands are available to column view, too; you can add those gray category headings to the clumps of files in each window. And, once again, you can use the Sort By commands to change the sequence of files within each grouping. It all works exactly as described starting on page 39.

### View Options

Just as in icon and list view, you can choose View→Show View Options to open a dialog box—a spartan one, in this case—offering additional control over your column views.
• **Always open in column view.** Once again, this option lets you override your system-wide preference setting for all windows. See page 35 for details.

• **Browse in column view.** Ensures that any folder inside this one will open up in column view when double-clicked.

• **Arrange By, Sort By.** You can put column-view icons into arranged groups—and sort them within those groups—just as described starting on page 39.

• **Text size.** Whatever point size you choose here affects the type used for icons in all column views.

• **Show icons.** For maximum speed, turn off this option. Now you see only file names—not the tiny icons next to them—in all column views. Weird!

• **Show icon preview.** Turn off this option if you don’t want the tiny icons in column view to display their actual contents—photos showing their images, Word and PDF documents showing their first pages, and so on. You get generic, identical icons for each file type (text, photo, or whatever).

• **Show preview column.** The far-right Preview column can be handy when you’re browsing graphics, sounds, or movie files. Feel free to enlarge this final column when you want a better view of the picture or movie; you can make it really big.

  The rest of the time, though, the Preview column can get in the way, slightly slowing down the works and pushing other, more useful columns off to the left side of the window. If you turn off this checkbox, then the Preview column doesn’t appear.

**Tip:** No matter what view you’re in, remember this: If you ever start dragging an icon and then change your mind, just press the Esc key or ^-period, even while the mouse button is still down. The icon flies back to its precise starting place. Or, if you’ve already dragged something to a new window and now you regret it, press ^-Z (for Undo). Too bad real life doesn’t have a similar feature.

**Cover Flow View**

Cover Flow simulates the flipping “pages” of a jukebox, or the albums in a record-store bin (Figure 1-24)—except that it’s not album covers you’re flipping; it’s gigantic file and folder icons.

To fire up Cover Flow, open a window. Then click the Cover Flow button (^) in the toolbar. Or choose View →as Cover Flow, or press ^-4.

Now the window splits. On the bottom: a traditional list view, complete with sortable, arrangeable columns, exactly as described previously. On the top: the gleaming, reflective-black Cover Flow display. Your primary interest here is the scroll bar. As you drag it left or right, you see your files and folders float by and flip in 3D space. Fun for the whole family!

The effect is spectacular, sure. It’s probably not something you’d want to set up for every folder, though, because browsing is a pretty inefficient way to find something.
But in folders containing photos or movies (that aren’t filled with hundreds of files), Cover Flow can be a handy and satisfying way to browse.

And now, notes on Cover Flow:

- You can adjust the size of the Cover Flow display (relative to the list-view half) by dragging up or down on the grip-strip area just beneath the Cover Flow scroll bar.

- Multipage documents, presentation files, movies, and sounds are special. When you point to one, you get either the ▶ button (to play a movie or a sound) or ➡ and ➡ arrow buttons (to flip through a PDF, Pages, PowerPoint, or Keynote document), exactly as you can with icons in icon view.

- You can navigate with the keyboard, too. Any icon highlighted in the bottom half of the window is also front and center in the Cover Flow view. Therefore, the usual list-view shortcuts can navigate both at once. Use the ▲ and ▼ keys, type the first letters of an icon’s name, and so on.

- Cover Flow shows whatever the list view shows. If you expand a flippy triangle to reveal an indented list of what’s in a folder, then the contents of that folder become part of the Cover Flow.

- The previews are actual icons. When you’re looking at a Cover Flow minidocument, you can drag it with your mouse—you’ve got the world’s biggest target—anywhere you’d like to drag it: another folder, the Trash, wherever.
• You can use the Arrange and Sort commands. You can group and sort the list-view portion of the window just as described starting on page 39.

**Keep Folders on Top**

Hiding away in Finder→Preferences→Advanced, a new option awaits in macOS Sierra: “Keep folders on top when sorting by name.”

That checkbox turns out to be incredibly useful (see Figure 1-25). In list or Cover Flow views, when you’ve sorted a window’s contents alphabetically, all the folders now appear at the top of the list, in their own little alphabetical grouping. (Otherwise, they appear mixed in with the loose files, all in one alphabetical list.)

![Figure 1-25:](image)

Actually, folders appear at the top of icon views, too. (In column view, oddly enough, folders appear in a sorted group at the *bottom* of the list!)

This “folders first” arrangement is, of course, how things work in Windows—and, although Apple may not have wanted to admit it for 30 years, it’s pretty handy.

**The Preview Pane**

The real magic of Cover Flow and column views has always been the instant previews of what’s in each file you highlight. The words in a Word file, the image in a JPEG
photo, the numbers in an Excel spreadsheet—you can see them without actually having to double-click an icon. In Cover Flow view, the preview image appears above the list of files (Figure 1-24); in column view, it appears in the rightmost column.

But what about icon and list views? They have charms of their own; don’t they deserve some kind of preview column, too? Now they have one. You can choose View→Show Preview (or press Shift-⌘-P) in any of the Finder’s four window views—and you get a full-height preview pane at the right side of the window (Figure 1-26). (To turn off the new pane, choose View→Hide Preview.)

Quick Look

As the preceding several thousand pages make clear, there are lots of ways to view and manage the seething mass of files and folders on a typical hard drive. Some of them actually let you see what’s in a document without having to open it—the Preview column in column view, the giant icons in Cover Flow, the new preview pane, and so on.

Quick Look takes this idea to another level. It lets you open and browse a document at nearly full size—without switching window views or opening any new programs (see Figure 1-27). You highlight an icon (or several) and then do one of these things:

- **Press the space bar.** This is by far the best technique to learn. After all, unless you’re editing a file’s name, what’s the space bar ever done for you in the Finder? Nothing. But in macOS, you can highlight any icon and then tap the space bar for an instant preview.

- **Tap with three fingers.** Here’s a bonus for laptops. Tap an icon with three fingers on the trackpad (don’t fully click down) to open its preview.

- **Press ⌘-Y.** Another keystroke for the same function. The space bar is still better, though.
• Click the 📀 icon at the top of the window. But who uses the mouse anymore?
• Choose File → Quick Look.
• Choose Quick Look from the Action menu (fullscreen) at the top of every Finder window.
• Right-click (or two-finger click) an icon; from the shortcut menu, choose Quick Look.
• Tap the 📀 icon on your Touch Bar (page 233), if you have one.

You exit Quick Look in any one of these same ways.

**Note:** Whenever Quick Look appears in a menu or a shortcut menu, its wording changes to reflect the name of the icon. For example, it might say “Quick Look ‘Secret Diary.doc.’”

In any case, the Quick Look window now opens, showing a gigantic preview of the document (Figure 1-27). Rather nice, eh?

---

**Figure 1-27:**
Once the Quick Look window is open, you can play a file (movies and sounds), study it in more detail (most kinds of graphics files), or even read it (PDF, Word, and Excel documents). You can also click another icon, and another, and another, without ever closing the preview; the contents of the window simply change to reflect whatever you’ve just clicked.

**Bonus tip:** Quick Look works even on icons in the Trash, so you can figure out what something is before you nuke it forever.
The idea here is that you can check out a document without having to wait for it to open in the traditional way—at full size. For example, you can read the text in a Word or PowerPoint document without actually having to open Word or PowerPoint, which saves you about 45 minutes.

**Tip:** You can use the usual “next page” gesture (two-finger swipe on a trackpad, one-finger swipe on the Magic Mouse) to page through PDF or iWork documents, or to move among photos if you’ve highlighted a whole bunch. Add the Option key to your finger-swipe to zoom in or out of PDF documents.

It’s astonishing how few Mac fans are aware of this incredibly useful feature. Learn it!

### What Quick Look Knows

Quick Look doesn’t recognize all documents. If you try to preview, for example, a Final Cut Pro video project, a sheet-music file, a .zip archive, or a database file, all you’ll see is a six-inch-tall version of its generic icon. You won’t see what’s inside.

People can write plug-ins for those nonrecognized programs. For example, plug-ins that let you see what’s inside folders and .zip files await at www.quicklookplugins.com. In the meantime, here’s what Quick Look recognizes right out of the box:

- **Graphics files and photos.** This is where Quick Look can really shine, because it’s often useful to get a quick look at a photo without having to haul Photos or Photoshop out of bed. Quick Look recognizes all common graphics formats, including TIFF, JPEG, GIF, PNG, RAW, and Photoshop documents.

- **PDF and text files.** Using the scroll bar, you can page through multipage documents, right there in the Quick Look window.

- **Audio and movie files.** These begin to play instantly when you open them into the Quick Look window. Most popular formats are recognized (MP3, AIFF, AAC, MPEG-4, H.264, and so on). A scroll bar appears so that you can jump around in the movie or song.

- **Pages, Numbers, Keynote, and TextEdit documents.** Naturally, since these are Apple programs, Quick Look understands the document formats.

- **Microsoft Word, Excel, and PowerPoint documents.** Move through the pages using the vertical scroll bar; switch to a different Excel spreadsheet page using the Sheet tabs at the bottom.

- **Fonts.** Totally cool. When you open a font file in Quick Look, you get a crystal-clear, huge sampler that shows every letter of the alphabet in that typeface.

- **vCards.** A vCard is an address-book entry that people can send by email to save time in updating their Rolodexes. When you drag a name out of Apple’s or Microsoft’s address books and onto the desktop, for example, it turns into a vCard document. In Quick Look, the vCard opens up as a handsomely formatted index card that displays all the person’s contact information.
• HTML (web pages) and Safari archived pages. If you’ve saved some web pages to your hard drive, here’s a great way to inspect them without firing up your web browser.

In fact, Quick Look has started seeping into other programs—not just the Finder. For example, you can preview any of the following:

• A link in a Mail message. In Mail, there’s a tiny ▼ next to each web link. Click it to view the actual web page it leads to, right there in a pop-up bubble!

• An address in Mail. If you ever see a street address in an email message, click the tiny ▼ next to it. You’re offered the option to add this person to your address book, or to see a map of that address in Safari, courtesy of Google Maps.

• Files in the Open dialog box. From within any program, whenever you choose File→Open to view the list of files and folders on your drive, you can tap the space bar to get an instant preview of each.

• An address in Contacts. In the Contacts program, click the label for an address (like “Work” or “Home”); from the shortcut menu, choose Map This Address. You get to see, once again, an aerial photo of that spot in Safari.

• Anything in Mission Control or a Dock menu. You can also tap the space bar to get a Quick Look preview of anything in the Mission Control view (page 182) or the stack, list, or grid of a Dock folder (page 140).

And you were alive to see the day!

The Quick Look Slideshow
The Mac is supposed to be all about graphics and other visual delights. No wonder, then, that it offers a built-in, full-screen slideshow feature.

It works like this: Highlight a bunch of icons, and then open Quick Look. Click the岙 (Full Screen) button in the top-left corner. The screen goes black, and the documents begin their slideshow. Each image appears on the screen for about 3 seconds before the next one appears. (Press the Esc key or ⌘-period to end the show.) It plays all documents it recognizes, not just graphics.

It’s a useful feature when you’ve just downloaded or imported a bunch of photos or Office documents and want a quick look through them. Use the control bar shown in Figure 1-28 to manage the playback.

**Note:** This same slideshow mechanism is available for graphics in Preview and Mail; Preview even offers crossfades between pictures.

Fun with Quick Look
Here are some stunts that make Quick Look even more interesting:

• Full screen. When you click the Full Screen button (the gray岙), the Quick Look window expands to fill your screen. Keep this trick in mind when you’re trying
to read Word, Excel, or PDF documents, since the text is usually too small to read otherwise. (When you’re finished with the closeup, click the Full Screen button again to restore the original Quick Look window, or the ❌ button to exit Quick Look altogether.)

**Tip:** How’s this for an undocumented shortcut? If you press Option-space bar, or Option-click the eyeball icon in any Finder window, you go straight into Full Screen mode without having to open the smaller Quick Look window first. Kewl.

(OK, this is actually part of the slideshow feature, but it’s also good for super-enlarging a single icon.)

---

**Figure 1-28:** Once the slideshow is underway, you can use this control bar. It lets you pause the slideshow, move forward or backward, enlarge the “slide” to fill the screen, or end the show. The Index view is especially handy. (You can press ⌘-Return to “click” the Index View button.) It displays an array of labeled miniatures, all at once—a sort of Exposé for Quick Look. Click a thumbnail to jump directly to the Quick Look document you want to inspect.

---

- **Share it.** Click the ⬇️ in the title bar to open the Share pop-up menu—a quick way to send this document on to somebody or to post it online.

- **Open with [program name].** This button shows up at the top-right corner of your Quick Look window. It might say, for example, Open with Preview.

  Handy, really. It says: “Oh, so you’ve been Quick Looking to find a particular document, and this is the one you wanted? Click me to jump directly into the program that opens it, so you can get to work reading or editing. I’ve just saved your having to close the window and double-click the icon.”

**Tip:** Actually, you have a much bigger target than the “Open with” button in the corner. You can double-click anywhere in the Quick Look window to open the document (in whatever program is named on the “Open with” button).
Better yet: If you click and hold your cursor on that “Open with” button, then you get a secret pop-up menu of other programs that could open the file you’re looking at.

- **Keep it going.** Once you’ve opened Quick Look for one icon, you don’t have to close it before inspecting another icon. Just keep clicking different icons (or pressing the arrow keys to walk through them); the Quick Look window changes instantly with each click to reflect the new document.

- **Fix the size.** Quick Look tries to display an entire picture or document in a single small window. To view it at actual size, hold down the Option key.

**Finder Tabs**

The world discovered the miracle of tabs in *web browsers* years ago. It was a simple software design idea, modeled after the tabs of paper file folders, that let you keep multiple web pages open at once in a single window. What convenience! What cleanliness!

But it took until 2013 for someone to realize that tabs might be useful at the desktop, too. That’s when Apple added tabs to Finder windows.

They do exactly the same job they do in Safari: They let you keep open the windows of several different containers—folders or disks—in a single window frame. That makes it easy to move icons back and forth between them (Figure 1-29), or even to view the same window twice in different views.

As a convenience, Apple designed the commands, keystrokes, and clicks to work exactly as they do in Safari.

**Creating Tabs**

There are almost as many ways to open new tabs as there are people:

- Press the *⌘* key as you open a folder or disk. (That shouldn’t come as a shock; you *⌘*-click a link to open a new tab in Safari, too.)

**Tip:** You can *⌘*-click the names of places in the Sidebar of a Finder window, too, like Documents or Pictures.

- Right-click (or two-finger click) a folder or disk. From the shortcut menu, choose Open in New Tab.
- If you already have some tabs, then click the + button at the far right. (Even if you haven’t created any tabs yet, that button appears if you’ve made the tab bar visible; choose View → Show Tab Bar.)
- Drag a disk or folder icon onto the + button at the far right of the tab bar.
- Select a folder or disk (or several). From the ⌥ menu, choose Open in New Tab(s)—or press Control-⌘-O.
• Choose File→New Tab, or press ⌘-T.

**Tip:** And what will it show? Whatever you’ve chosen in the Finder→Preferences→General→”New Finder windows show” pop-up menu. It’s usually your All My Files window, or maybe the desktop’s contents.

• A New Tab button is also available to install onto your Touch Bar, if you have one of those on your laptop (page 233).

**Using Tabs**

So why bother opening tabs? Because you can perform a few power-user stunts now that you couldn’t before. Like this:

• **Move files around.** You can drag a file or folder icon into another tab, as shown in Figure 1-29.

![](Finder Tabs.png)

---

**Figure 1-29:** Finder tabs are just like tabs in a browser. They let you view multiple folders or disks in a single window.

**Tip:** If you drag a file onto a new tab (like Recipes, shown here) and let go, you move that icon. If you move it to the Recipes tab and pause, finger still down, the Recipes tab opens so that you can continue your drag into a folder you find there.

• **View the same window twice.** Put one copy of the window in list view, another in icon view. Or view different sections of a long list of files in two side-by-side tabs.

• **Live in a desktop-free world.** Click the green ⊇ button (upper-left corner) to put your Finder window into Full Screen mode. (See page 177 for more on Full Screen mode.)

Now you can work in tabs, manipulating your files, without ever seeing the desktop.

**Tab Management**

Once you’ve got some tabs adorning your window, you can operate them thusly:

• **To switch tabs,** click one, or press Control-Tab. (Add the Shift key to cycle through the tabs in reverse.) If you forget these important keystrokes, they’re listed for you as commands in the Window menu.
• **Rearrange tabs** by dragging them horizontally.

• **Turn a tab into a standalone window** by dragging it away from the other tabs. (Or choose Window→Move Tab to New Window.)

**Tip:** There’s no built-in keyboard shortcut for the Window-menu commands like Move Tab to New Window and Merge All Windows. But it’s easy enough to add a shortcut of your own, as described on page 210.

• **Move a tab into a different window** by dragging it. That is, you can drag a tab from one window to another.

• **Round up a bunch of open windows** into a single tabbed window: Choose Window→Merge All Windows. That’s a good one.

• **To close a tab,** press the usual “close window” keystroke, ⌘-W. (Or, if it’s a slow day at work, choose File→Close Tab. Or move your cursor onto the tab itself and click the tiny ✗ that appears.)

• **To close all tabs,** add the Option key. For example, press Option-⌘-W or Option-click the window’s red Close button.

### Tabs in Other Apps

Apparently, you just can’t keep a good idea down. Tabbed windows, which did so well in web browsers, eventually made their way to the Finder—and in Sierra, they’re now in six other Apple programs: Mail, Maps, TextEdit, Pages, Keynote, and Numbers. Some non-Apple apps that are “document-based” (you work in multiple windows, each containing a different document) also gain tabs in Sierra—automatically.

For one reason or another, you don’t get tabbed windowing in any other built-in Apple apps. And you don’t get it in Microsoft or Adobe programs.

If you’re using one of the anointed apps, start by opening at least two windows. (Some apps, like Mail, create a new tab when you choose File→New Tab.) Choose Window→Merge All Windows to turn them into tabs. At this point, a + button appears at the top right of a window, so that you can create a new blank tab.

**Tip:** If you like, those apps can open a new tab, rather than a separate window, every time you create a new document. In System Preferences→Dock, the “Prefer tabs when opening documents” pop-up menu offers three choices. “Automatically” means that every new document will appear in a tab. “In Full Screen Only” means that new documents become tabs only when you’re in Full Screen mode (page 177). And “Manually” means that new tabs appear only when you use the New Tab command.

At that point, you can switch tabs, rearrange them, close them, and separate them exactly as described already.
Logging Out, Shutting Down

If you’re the only person who uses your Mac, finishing up a work session is simple. You can either turn off the machine or simply let it go to sleep, in any of several ways.

Sleep Mode

If you’re still shutting down your Mac every night, you may be doing a lot more waiting than necessary. Sleep mode consumes very little power, keeps everything you were doing open and available, and wakes up almost immediately.

To make your machine sleep, do one of the following:

• Close the lid. (Hint: This works primarily on laptops.)
• Press the power button (⊞) on your Mac. Tapping that button (for about a half-second) makes any kind of Mac drop off to sleep instantly.
• Hold down the power button (⊞) for 2 seconds. You get the box shown in Figure 1-30; hit Sleep (or type S).
• Choose ⧿ → Sleep. Or press Option-⌘-⏏.
• Press Control-⏏. In the dialog box shown in Figure 1-30, click Sleep (or type S).
• Tap the Sleep button on your Touch Bar, if you have one (and if you’ve installed the Sleep button there; see page 237).
• Just walk away, confident that the Energy Saver setting in System Preferences will send the machine off to dreamland automatically at the specified time.

Tip: Ordinarily, closing your MacBook’s lid means cutting it off from the world. But the Power Nap feature lets your Mac stay connected to your network and to the Internet, even while it’s otherwise sleeping. It can download email, back up your stuff, download software updates, and so on. For details, see page 354.
Restart
You shouldn’t have to restart the Mac very often—only in times of severe troubleshooting mystification, in fact. Here are a few ways to do it:

• Choose 🍀 → Restart. A confirmation dialog box appears; click Restart (or press Return).

**Tip:** If you press Option as you release the mouse on the 🍀 → Restart command, you won’t be bothered by an “Are you sure?” confirmation box.

• Press Control-⌘-`. 

• Press Control-∆ (or hold down the ⌘ button) to summon the dialog box shown in Figure 1-30; click Restart (or type R).

Shut Down
To shut down your machine completely (when you don’t plan to use it for more than a couple of days, when you plan to transport it, and so on), do one of the following:

• Choose 🍀 → Shut Down. A simple confirmation dialog box appears; click Shut Down (or press Return).

**Tip:** Once again, if you press Option as you release the mouse, no confirmation box appears.

• Press Control-Option-⌘-`. (It’s not as complex as it looks—the first three keys are all in a tidy row to the left of the space bar.)

• Press Control-∆ (or hold down the ⌘ button) to summon the dialog box shown in Figure 1-30. Click Shut Down (or press Return).

• Wait. If you’ve set up the Energy Saver preferences (page 351) to shut down the Mac automatically at a specified time, then you don’t have to do anything.

The “Reopen windows” Option
In the Shut Down dialog box illustrated in Figure 1-30, you’ll notice a checkbox called “Reopen windows when logging back in.” That option does something very useful: The next time you start up your Mac, every running program, and every open window, will reopen exactly as they were at the moment you used the Restart or Shut Down command. This saves you a lot of reopening the next time you sit down to work.

If you turn off that checkbox when you click Restart or Shut Down, then your next startup will take you to the desktop, with no programs running, as though this were still some year between 1984 and 2010. And if you want the Mac to stop asking—if you never want your programs and windows to reopen—then open System Preferences → General, and turn on “Close windows when quitting an app.”
## Log Out

If you share your Mac, then you should log out when you’re done. Doing so ensures that your stuff is safe from the evil and the clueless even when you’re out of the room. To do it, choose ⌘ → Log Out [your name], or press Shift-⌘-Q.

When the confirmation dialog box appears, click Log Out (or press Return) or just wait for 1 minute (a message performs the countdown for you). The Mac hides your world from view and displays the Log In dialog box, ready for its next victim.

**Tip:** One more time: If you press Option as you release the mouse on the ⌘ → Log Out command, you squelch the “Are you sure?” box.

Logging out is described in much more detail in Chapter 12.

### Getting Help in macOS

It’s a good thing you’ve got a book about macOS in your hands, because the only manual you get with it is the Help menu, a browser-like program that reads a set of help files that reside in your System → Library folder.

---

**Menu Help in the Help Menu**

MacOS contains a weird, wonderful little enhancement to its online help system. It helps you find menu commands.

You’re floundering in some program. You’re sure there’s a page numbering command in those menus somewhere. But there are 11 menus, and 143 submenus, hiding in those menus, and you haven’t got time for the pain.

That’s when you should think of using the Help menu. When you type page number (or whatever) into its search box, the results menu lists, at the top, the names of any menu commands in that program that contain the words you typed. Better still, it actually opens that menu for you, and displays a big, blue, animated, floating arrow pointing to the command you wanted. Simply slide your cursor over, click the menu command you wanted, and get on with your life.

Supertip: This feature is especially helpful in web browsers like Safari and Firefox, because it even finds entries in your Bookmarks and History menus!

In Safari, for example, you can pluck a recently visited site out of the hundreds in the daily History submenus, like the “Wednesday, January 4” submenu. You’ve just saved yourself a lot of poking around menus, trying to find the name of a site you know you’ve seen recently.

Ultratip: If you think about it, this feature also means that you have complete keyboard power over every menu in every program in the world. Hit Shift-⌘-/ (that is, ⌘-?) to open the Help search box, type a bit of the command’s name, and then use the arrow keys to walk down the results. Hit Return to trigger the command you want.
Tip: In fact, you may not even be that lucky. The general-information help page about each topic is on your Mac, but thousands of the more technical pages reside online and require an Internet connection to read.

You’re expected to find the topic you want in one of these three ways:

• **Use the search box.** When you click the Help menu, a tiny search box appears just beneath your cursor (Figure 1-31). You can type a few words here to specify what you want help with: “setting up printer,” “disk space,” whatever.

Tip: You can also hit Shift-⌘-/ (that is, ⌘-?) to open the help search box. And you can change that keystroke, if you like, in System Preferences → Keyboard → Shortcuts → App Shortcuts.

![Figure 1-31: You don't have to open the Help program to begin a search. No matter what program you're in, typing a search phrase into the box shown here produces an instantaneous list of help topics, ready to read.](image)

After a moment (sometimes several moments), the menu becomes a list of Apple help topics pertaining to your search. Click one to open the Help browser described next; you’ve just saved some time and a couple of steps.

Tip: The results menu does not, however, show all of Help’s results—only the ones Apple thinks are most relevant. If you choose Show All Help Topics at the bottom of the menu, the Help browser (described next) opens. It shows a more complete list of Help search results.

• **Drill down.** Alternatively, you can begin your quest for assistance the old-fashioned way: by opening the Help browser first. To do that, choose Help → Mac Help. (In other programs, it might say, for example, “Mail Help.” Either way, this command appears only when nothing is typed in the search box.)

After a moment, you arrive at the Help browser shown at top in Figure 1-32. The starting screen offers several “quick click” topics that may interest you under “Show topics”—presumably the ones that trigger the most help-hotline calls to Apple. If so, keep clicking text headings until you find a topic you want to read.

You can backtrack by clicking the < button at the top of the window.
Tip: Annoyingly, the help window insists on floating in front of all other windows; you can’t send it to the back like you can any normal program. Therefore, consider making the help window tall and skinny, so that you can put it alongside the program you’re working in. Drag any edge of the box to change the window’s shape.

- Use the search box. Type the phrase you want, like printing or switching applications, into the search box at the top of the window, and then press Return. As you type, a list of proposed matches drops down from the search box. When you click the closest match, you’re shown a list of help-screen topics that may pertain to what you need; see Figure 1-32 for details.

Note: Actually, there’s one more place where Help crops up: in System Preferences dialog boxes. Click the circled question-mark button (?) in the lower-right corner of most System Preferences panels to open a help page that identifies each control.

Figure 1-32: Mac Help (top) likes to help with big-ticket computer tasks like joining a network, setting up your email program, or browsing the web. Once you perform a search for some topic (middle), you get a details page (bottom) that offers a list of finely grained step-by-steps.

The Help windows try to be helpful by floating stubbornly in front of all your other windows. That, actually, can be frustrating, since you can’t see the software you’re reading about. The best solution is to make the window narrow and park it at the edge of your screen.
O’Reilly ebooks.
Your bookshelf on your devices.

When you buy an ebook through oreilly.com you get lifetime access to the book, and whenever possible we provide it to you in four DRM-free file formats—PDF, .epub, Kindle-compatible .mobi, and DAISY—that you can use on the devices of your choice. Our ebook files are fully searchable, and you can cut-and-paste and print them. We also alert you when we’ve updated the files with corrections and additions.

Learn more at ebooks.oreilly.com

You can also purchase O’Reilly ebooks through the iBookstore, the Android Marketplace, and Amazon.com.